IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2004 XC70 engine shuts off, poor running

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

oceanview12
Posts: 2
Joined: Mon Sep 30, 2019 1:15 am
Year and Model: 2004
Location: bc
Has thanked: 0
Been thanked: 0
Canada
oceanview12

2004 XC70 engine shuts off, poor running

Post by oceanview12 » Mon Sep 30, 2019 1:52 am

hello, found this forum thru google... need some help diagnosing...

2004 xc70 awd w/turbo...

so the car started randomly shutting off when coming to a stop or after stopping; just turn the key and it would start back and run fine for days then start the random shut offs; sometimes a few times a day.

noticed the following now...

when starting up one has to keep feathering the ex at higher rpm's while the engine is running; the engine seems to sputter/miss fire but feathering between low to high rpm's clears it and eventually after about 2/5 minutes it idles, which it does very smoothly;

once the engine is turned off and you try to restart, you have to do the above steps again. it sometimes feel like it moisture/water in the fuel as the sputtering/popping sounds reminds me of the old carb type engines;

i'm at a loss now as to what to look at; I do have a fuel pump and throttle body from a scrapped car (exact same model) but i'm hoping it could be something minor or simple that i have not checked yet;

i replaced the fuel filter and added some methyl hydrate to absorb any moisture/water in the tank... still the same symptoms

and ideas...



User avatar
abscate
MVS Moderator
Posts: 18394
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 205 times
Been thanked: 683 times
Trinidad & Tobago
abscate

Re: 2004 XC70 engine shuts off, poor running

Post by abscate » Mon Sep 30, 2019 4:56 am

That’s a common behaviour with an. Induction path leak, a break or misplaced hose between the air cleaner and the throttle body. You have to remove each piece and inspect carefully, you cannot inspect visually in a meaningful way


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
oragex
Posts: 4337
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 83 times
Been thanked: 195 times
Contact:
Canada
oragex

Re: 2004 XC70 engine shuts off, poor running

Post by oragex » Mon Sep 30, 2019 10:21 am

Read about FPS and PEM

Also have a look with a flash light at the CEM, search for what may look like traces on the cover from a water leak - may google as well about this common issue

If there is a misfire, it's usually a bad coil (will need to also put fresh plugs) www.youtube.com/watch?v=fnYUQh23p7Q



oceanview12
Posts: 2
Joined: Mon Sep 30, 2019 1:15 am
Year and Model: 2004
Location: bc
Has thanked: 0
Been thanked: 0
Canada
oceanview12

Re: 2004 XC70 engine shuts off, poor running

Post by oceanview12 » Mon Sep 30, 2019 8:23 pm

thank you both for your input... i will start looking there...

oragex do you mean the computer elec modules under the
hood...

abscate.... it should be noted that a air tube to the turbo broke
at the bend many months ago, but the problem started happening
months later...

ps... fond memories... time for some ponce de creme and
some pastels soon...i know de flag well...



User avatar
abscate
MVS Moderator
Posts: 18394
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 205 times
Been thanked: 683 times
Trinidad & Tobago
abscate

Re: 2004 XC70 engine shuts off, poor running

Post by abscate » Tue Oct 01, 2019 4:04 am

oceanview12 wrote:
Mon Sep 30, 2019 8:23 pm
thank you both for your input... i will start looking there...

oragex do you mean the computer elec modules under the
hood...

abscate.... it should be noted that a air tube to the turbo broke
at the bend many months ago, but the problem started happening
months later...

ps... fond memories... time for some ponce de creme and
some pastels soon...i know de flag well...
Together we achieve...... :D


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

Post Reply