IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2004 XC70 Brake component in engine compartment

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

malcolmtent
Posts: 9
Joined: Thu Feb 12, 2015 7:21 am
Year and Model: S60R 2004
Location: Albany, NY
Has thanked: 1 time
Been thanked: 0
United States of America
malcolmtent

2004 XC70 Brake component in engine compartment

Post by malcolmtent » Fri Oct 11, 2019 6:01 am

2004 XC70

I've been chasing a problem with my brake lights. At first my 2 lower brake lights wouldn't come on, but the top light did. But now the top light isn't coming on, either.

I've noticed a buzzing sound coming from the engine compartment while pressing the brake pedal and am wondering what component might be causing the sound. It's coming from lower in the engine compartment than the fusebox.

I'm pretty sure (but not entirely sure) that this is a new sound, and wondering if it's connected to the issue of my top brake light not working.

What would this component be?

Thanks.



User avatar
oragex
Posts: 4346
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 84 times
Been thanked: 197 times
Contact:
Canada
oragex

Re: 2004 XC70 Brake component in engine compartment

Post by oragex » Fri Oct 11, 2019 6:36 am

The sound is the vacuum pump www.youtube.com/watch?v=PRbWD2OGytk
You can test it see if it works correctly www.youtube.com/watch?v=xwQG7xvXVp8
However the brake lights are not related to the pump.
The two lower lights may be related to the REM
https://www.volvoforums.org.uk/showthread.php?t=289930
viewtopic.php?f=9&t=89032&p=502180#p502180



malcolmtent
Posts: 9
Joined: Thu Feb 12, 2015 7:21 am
Year and Model: S60R 2004
Location: Albany, NY
Has thanked: 1 time
Been thanked: 0
United States of America
malcolmtent

Re: 2004 XC70 Brake component in engine compartment

Post by malcolmtent » Fri Oct 11, 2019 1:19 pm

thanks, I'll test the vacuum pump. Yes, I'm aware that the rear lights may be the REM. I've eliminated just about everything else at this point, but am curious to know why the top brake light has suddenly decided to not work. I was thinking that the new noise in the engine compartment might be the problem.



Post Reply