Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

2004 s60 T

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive P2 platform cars sold as model years 2001-2007 (North American market year designations).

2001 - 2007 V70
2001 - 2004 V70 XC (Cross Country)
2004 - 2007 XC70 (Cross Country)
2001 - 2009 S60
2003 - 2007 S60 R
2004 - 2007 V70 R

Post Reply
ronjag
Posts: 10
Joined: Fri Oct 11, 2019 9:03 am
Year and Model: 2004 s60
Location: west midlands

2004 s60 T

Post by ronjag »

Hi, new member here, i am looking for possible help and advice.
I have the anti skid service message, a diagnostic came back as BCM 0139 brake booster, I removed the BCM and sent it off to ECUTESTING for a diagnostic, they said that the unit tested ok with no faults, When i received it back, I put it back onto the car and still get the message and error code, any advice would be greatly appreciated
Regards Ron

User avatar
RickHaleParker
Posts: 5686
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 4 times
Been thanked: 716 times

Post by RickHaleParker »

BCM-0139 Pressure build-up valve, power brake booster. Signal outside its permitted range

Diagnostic trouble code (DTC) information

Condition
Note! This diagnostic trouble code (DTC) applies only to brake systems with dynamic stability and traction control (DSTC).
During stability control the brake control module (BCM) transmits a signal to the pressure build-up valve. The valve opens and releases atmospheric pressure into the brake power booster. This increases the brake pressure in the brake system automatically. The function is used for traction control and in active brake assistance.
Diagnostic trouble code (DTC) BCM-0139 is stored if the control module registers an implausible signal from the pressure build-up valve.

Substitute value
Traction control is blocked
Stability control is blocked
Active yaw control is blocked
Brake assistance is blocked.


Possible source
  • Contact resistance or oxidation in the terminals or connections
    Short-circuit to ground or supply voltage in the wiring
    Incorrectly installed sensor
    Defective pressure build-up valve

    Internal fault in the control module.
Fault symptoms
  • General warning lamp lit
    The anti-spin warning lamp is lit (up to and including 2002 model year)
    Anti-spin does not function
    The stability control system does not function
    The traction control system does not function.
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

ronjag
Posts: 10
Joined: Fri Oct 11, 2019 9:03 am
Year and Model: 2004 s60
Location: west midlands

Post by ronjag »

Hi. My car only has STC and not DSTC, the STC button is constantly lit and does not go off when pressed, would this make a difference to the fault code BCM 0139, I realise there could be several causes for this but for the age/value of the car, im a little reluctant to spend a fortune on it, any ideas which is the most common cause of it assuming I now know that it isnt the control module.

User avatar
RickHaleParker
Posts: 5686
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 4 times
Been thanked: 716 times

Post by RickHaleParker »

Clean the electrical connectors.
Check loom for shorts.
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

earthworm
Posts: 36
Joined: Wed Dec 05, 2018 10:28 am
Year and Model: 2003 S60
Location: York County, PA

Post by earthworm »

An excellent trite up from Mr Parker .. the answer might be there .. indirectly .
I was going to say "15 years of corrosion" and the wiring insulation could be failing. . Check where the wiring is exposed to the elements and heat .. and grease .

User avatar
RickHaleParker
Posts: 5686
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 4 times
Been thanked: 716 times

Post by RickHaleParker »

earthworm wrote: Sat Oct 12, 2019 9:59 pm An excellent trite up from Mr Parker ..
Hum perhaps I shall endeavor to be more entertaining ... na I'll stick with the facts no matter how boring. :lol:
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

ronjag
Posts: 10
Joined: Fri Oct 11, 2019 9:03 am
Year and Model: 2004 s60
Location: west midlands

Post by ronjag »

Thanks for all the replies, is the pressure build up valve built into the abs pump?, at the front of the engine behind the nearside headlamp there is a 3 way valve with a sensor on it, when i disconnect this sensor and plug my diagnostic in, there are no other codes present, only he code i continually have 0139, so i am wondering if it could be that valve/sensor, i have 12v present at the sensor, so to my mind it is getting a voltage to it.

Post Reply