IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Melt wiring harness now all kinds of problems

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Trav91
Posts: 2
Joined: Wed Oct 16, 2019 10:46 pm
Year and Model: 2001 s60 2.4t
Location: Stockton
Has thanked: 0
Been thanked: 0
United States of America
Trav91

Melt wiring harness now all kinds of problems

Post by Trav91 » Thu Oct 17, 2019 1:40 am

I have a 01 s60 2.4t. My fan for radiator caught fire and melted the wiring harness above. Quick fixed it with some electrical tape and drove it home in limp mode. Now after going through the wires and re-connecting them properly and swapping out new radiator fan I have a Lotta codes and car is runningLike crap. Codes are p0103, p0118, p134, p0236, and p0238 . I am hoping I just fried sensors can I go to pick and pull and see if I can get some new ones hopefully I didn’t fry my ECu please help



chrism
Posts: 966
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Has thanked: 0
Been thanked: 19 times
chrism

Re: Melt wiring harness now all kinds of problems

Post by chrism » Thu Oct 17, 2019 6:51 am

I’m guessing all those codes, or the majority of them, are residual from when the wiring shorted out. I would try clearing the codes and see what pops up when you try starting it again. In some cases, like an O2 preheater circuit for instance, the fault code will pop up simply by turning on the ignition - you don’t even have to start the engine.



DrDan
Posts: 79
Joined: Wed Jul 19, 2017 12:29 pm
Year and Model: 02 V70
Location: Frankfurt
Has thanked: 0
Been thanked: 8 times
Germany
DrDan

Re: Melt wiring harness now all kinds of problems

Post by DrDan » Thu Oct 17, 2019 11:56 am

Woah, tough luck, I hope you get this resolved. Start with a careful analysis of damage not only in cables, but also hoses, connectors etc.
As for the codes, I would suspect:
p0118 - possibly short circuit because of melted cable to coolant temp sensor. Check with multimeter or look at live data from scanner, Torque or VIDA
p0103 - same for MAF
p0134 - same for O2
p0236, p0238 - same for MAP

Maybe also upload a photo to give an impression of the extent of the damage.



Trav91
Posts: 2
Joined: Wed Oct 16, 2019 10:46 pm
Year and Model: 2001 s60 2.4t
Location: Stockton
Has thanked: 0
Been thanked: 0
United States of America
Trav91

Re: Melt wiring harness now all kinds of problems

Post by Trav91 » Sat Oct 19, 2019 5:29 pm

DrDan wrote:
Thu Oct 17, 2019 11:56 am
Woah, tough luck, I hope you get this resolved. Start with a careful analysis of damage not only in cables, but also hoses, connectors etc.
As for the codes, I would suspect:
p0118 - possibly short circuit because of melted cable to coolant temp sensor. Check with multimeter or look at live data from scanner, Torque or VIDA
p0103 - same for MAF
p0134 - same for O2
p0236, p0238 - same for MAP

Maybe also upload a photo to give an impression of the extent of the damage.
Yeah I just pick up those sensors from pick and pull today I’m going to throw them in tomorrow... I didn’t get a O 2 sensor tho but I will keep it updated



Post Reply