2006 XC90 2.5T - couple things...

A mid-size luxury crossover SUV, the Volvo XC90 made its debut in 2002 at the Detroit Motor Show. Recognized for its safety, practicality, and comfort, the XC90 is a popular vehicle around the world. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
bfry
Posts: 34
Joined: Sun Mar 25, 2018 8:21 am
Year and Model: 2006 XC90 2.5T AWD
Location: NY
Has thanked: 22 times

2006 XC90 2.5T - couple things...

Post by bfry »

Mileage ~170k

Started car other morning - running very rough - CEL = P0300, P0304& P0305.

Started checking coils - 1&2 sparking fine - then and I don't know why I didn't finish checking the other coils, decided to do a compression test.

1-3 = 150
4 = 135
5 = 120

Go back out today to finish checking coils 3-5 and not getting a spark. Checked 1&2, which were good yesterday, but no spark this morning. What am I missing? Did I blow all the coils when doing the compression test because I didn't disconnect them?

Silly question, but plugs (all very corroded btw, picking up new ones right now) don't need to be in cylinder when doing a spark test right - not some kind of fail safe where computer detects no plugs so doesn't bother sending electricity to coils?

Thank you.

User avatar
oragex
Posts: 5302
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 102 times
Been thanked: 328 times
Contact:

Post by oragex »

To check any coil - try disconnecting the injector rather than the coil itself www.youtube.com/watch?v=nDwtZCWU7u8

I think they are made by Bosch

You'll need to replace the spark plugs - when worn they cause the coils to fail

User avatar
ggleavitt
Posts: 449
Joined: Sun Jun 04, 2006 11:33 pm
Year and Model: 06,08 XC90 V8
Location: Seattle
Been thanked: 66 times

Post by ggleavitt »

For coil pack, Bosch PN 0221604008 is the OEM version of the Volvo PN 30713416 at about 60% of the price.
2006 V8 AWD Ocean Race-136k
2008 V8 AWD Sport-136k

bfry
Posts: 34
Joined: Sun Mar 25, 2018 8:21 am
Year and Model: 2006 XC90 2.5T AWD
Location: NY
Has thanked: 22 times

Post by bfry »

Thanks for the reply’s above - so I picked up new plugs and new coil packs.

Turns over, sounds like it’s gonna start but no go.

Checked fuse to fuel pump - it’s fine.

Any thoughts?

wanderdüne
Posts: 215
Joined: Thu May 18, 2017 5:24 pm
Year and Model: 2004, 2006 XC90 2.5T
Location: kitchen
Has thanked: 5 times
Been thanked: 43 times

Post by wanderdüne »

Check to see if you are getting fuel pressure at the rail. Use a rag to catch spray/excess fuel and depress the shrader valve on the fuel rail.

bfry
Posts: 34
Joined: Sun Mar 25, 2018 8:21 am
Year and Model: 2006 XC90 2.5T AWD
Location: NY
Has thanked: 22 times

Post by bfry »

fuse 10 was blown - replaced and gtg - somehow musta blown when doing the compression test yesterday and would explain why no spark today. Running smooth now...

Thank you for the responses.

bfry
Posts: 34
Joined: Sun Mar 25, 2018 8:21 am
Year and Model: 2006 XC90 2.5T AWD
Location: NY
Has thanked: 22 times

Post by bfry »

Fuse 10 in engine bay to be precise = ignition coils, ecm

User avatar
oragex
Posts: 5302
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 102 times
Been thanked: 328 times
Contact:

Post by oragex »

Good fix! May look at the wires to the coils, sometimes the insulation may crack and touch the metal, or may get crushed under the black cover. Also good to look at the engine ground wire, I believe somewhere behind the top of the engine, close to the timing belt side

Post Reply