IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2000 S80 in-car Transmission rebuild problem

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
thr3shold
Posts: 5
Joined: Fri Sep 11, 2015 2:55 pm
Year and Model: S80 2000
Location: Upstate, New York
Has thanked: 0
Been thanked: 0
United States of America
thr3shold

2000 S80 in-car Transmission rebuild problem

Post by thr3shold » Sat Oct 19, 2019 3:33 pm

I'm utilizing Oly_850's great write up to attempt my in-car transmission rebuild but have run into a roadblock; both the steering shaft u-joint retaining bolt and the rack and pinion bolt into the engine both seem like they want to shear right off. I've soaked them best I could in penetrating fluid, but are there any suggestions? Assuming I can't remove either bolt without shearing it off is there even any way forward? Thanks for all your help in advance.



thr3shold
Posts: 5
Joined: Fri Sep 11, 2015 2:55 pm
Year and Model: S80 2000
Location: Upstate, New York
Has thanked: 0
Been thanked: 0
United States of America
thr3shold

Re: 2000 S80 in-car Transmission rebuild problem

Post by thr3shold » Sun Oct 20, 2019 12:33 pm

Solved. The bolts just needed time for the oil to work? Plus whacking it some more and they both came free.



User avatar
SuperHerman
Posts: 1229
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 115 times
United States of America
SuperHerman

Re: 2000 S80 in-car Transmission rebuild problem

Post by SuperHerman » Tue Oct 22, 2019 9:30 pm

My only words of wisdom is to pressure test your seals before reinstalling the clutch assembly. I did the job, it is not bad.



thr3shold
Posts: 5
Joined: Fri Sep 11, 2015 2:55 pm
Year and Model: S80 2000
Location: Upstate, New York
Has thanked: 0
Been thanked: 0
United States of America
thr3shold

Re: 2000 S80 in-car Transmission rebuild problem

Post by thr3shold » Wed Nov 20, 2019 4:20 am

I finished the job and everything seemed great(smooth crisp shifts over 5 miles), but then the transmission started acting funny during a longer trip(burned clutch smell and a feeling of bogging down/resistance). I realized I didn't reset the transmission computer to have it adapt to all the new parts, but I haven't touched my VADIS laptop setup in 4 years and I'm having trouble getting it working again. Is there an alternate method to clear the computer memory?



Post Reply