IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

High Beam/dashboard lighting issue

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

TommyC
Posts: 5
Joined: Mon Oct 21, 2019 10:19 am
Year and Model: 2003
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
TommyC

High Beam/dashboard lighting issue

Post by TommyC » Mon Oct 21, 2019 1:19 pm

Hello. I'm new to the forum and have a question involving a 2003 V70. The other night I got in the car, turned the ignition on and some of the dashboard lights and radio lights are super dim. In addition, the high-beam lights will not stay in the high-beam position. Bulbs are good, fuses good. The light switch is in the 12:00 position, leaving only the Daytime running lights the only lights working.

Has anyone dealt with this issue and is there a specific relay on the central electronic module (CEM) that controls these lights?

I stuck a mirror and flashlight under the dash at the (CEM) and don't see any corrosion or fretting of wires.

Any help would be appreciated. Thanks.



User avatar
oragex
Posts: 4391
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 89 times
Been thanked: 206 times
Contact:
Canada
oragex

Re: High Beam/dashboard lighting issue

Post by oragex » Mon Oct 21, 2019 6:01 pm

May try the other settings on the light switch know, only one keeps the high beam on. Do you still see the blue high beam light on the dashboard ? Did the car battery went flat recently ? May be worth measuring the battery and the alternator charge

I'm thinking either DIM failure - your 2003 is in the range for this, or a problem with the cabin light sensor located on the radio unit face - located at the bottom in between the two knobs - try covering it with you finger see if the light is still dim.



TommyC
Posts: 5
Joined: Mon Oct 21, 2019 10:19 am
Year and Model: 2003
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
TommyC

Re: High Beam/dashboard lighting issue

Post by TommyC » Mon Oct 21, 2019 6:34 pm

Thanks for your response oragex. I'll check battery/ alternator. The high beams can be flashed but they don't stay on. Also the DTR lights are on in all three positions on control, including in park (middle). position. This has me stumped.

The local Volvo dealer said it may be a software glitch. Hopefully not that deep. Any how I can't get the car inspected untill it is fixed.

Thanks.



DrDan
Posts: 78
Joined: Wed Jul 19, 2017 12:29 pm
Year and Model: 02 V70
Location: Frankfurt
Has thanked: 0
Been thanked: 8 times
Germany
DrDan

Re: High Beam/dashboard lighting issue

Post by DrDan » Tue Oct 22, 2019 6:58 am

oragex wrote:
Mon Oct 21, 2019 6:01 pm
I'm thinking either DIM failure - your 2003 is in the range for this, or a problem with the cabin light sensor located on the radio unit face - located at the bottom in between the two knobs - try covering it with you finger see if the light is still dim.
As the dimming level is controlled via CANBUS and several devices are affected, I would also guess that the ambient light sensor could be involved (reading bright day when it's really dark). However, the light sensor on the radio is for the infrared remote if I'm not mistaken. Ambient light sensor would be on top of the dash, under the internal rear view mirror.
At the same time, DIM failure would not explain the radio dimness I guess.

For the high beam, could this be an issue with the switch, I mean the one on the next to the steering wheel? I'm having issues with the one controlling the window washers, it only engages if carefully pushed to intermediate position so I guess they do fail.



TommyC
Posts: 5
Joined: Mon Oct 21, 2019 10:19 am
Year and Model: 2003
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
TommyC

Re: High Beam/dashboard lighting issue

Post by TommyC » Wed Oct 23, 2019 12:39 pm

Thanks Dr. Dan. It's just weird that all this happened at the same time which is why I thought the 2 issues may be related. I will look into the switch and the control arm. I have noticed it's a bit wonky when turn signal is pushed down for left turns. Thanks again all.



ljsommar1
Posts: 14
Joined: Thu Jul 18, 2019 10:10 am
Year and Model: 2002V70
Location: Pennsylvania
Has thanked: 0
Been thanked: 2 times
United States of America
ljsommar1

Re: High Beam/dashboard lighting issue

Post by ljsommar1 » Wed Oct 23, 2019 6:29 pm

I experienced very similar symptoms on my 2002 V70. The solution for me was a replacement (junkyard) headlight switch. If that is your problem, the switch replacement is a 2-5 minute job.
Open drivers door, remove panel, insert hand, squeese tabs on switch, push switch forward, disconnect connector, reverse process with replacement switch. I didn't even disconnect battery but I suppose that would be recommended.
I attempted to repair my original switch before I replaced it, with mixed results but it did confirm that the switch was bad.



TommyC
Posts: 5
Joined: Mon Oct 21, 2019 10:19 am
Year and Model: 2003
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
TommyC

Re: High Beam/dashboard lighting issue

Post by TommyC » Wed Oct 23, 2019 7:48 pm

ljsommar1

I appreciate the advice. you are the second one to give this as a possible solution. I will definitely be adding this to my trouble shooting. eBay Volvo parts seller mentioned this to me today.

Thanks



User avatar
darylrobert
Posts: 155
Joined: Tue Jul 13, 2010 11:16 pm
Year and Model: V70 240 740t xc70
Location: Australia
Has thanked: 0
Been thanked: 1 time
Australia
darylrobert

Re: High Beam/dashboard lighting issue

Post by darylrobert » Fri Oct 25, 2019 4:43 am

fairly sure its the headlight switch thats the problem, not sure if they are swapable but ive seen a video where someone took theirs apart and re-soldered some joints. ive noticed my lights go dim for a few seconds then come back normal...probably early stages of failure.



TommyC
Posts: 5
Joined: Mon Oct 21, 2019 10:19 am
Year and Model: 2003
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
TommyC

Re: High Beam/dashboard lighting issue

Post by TommyC » Fri Oct 25, 2019 5:28 am

Got one coming eBay $20.00. thanks



Post Reply