IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

2004 xc90 T6 runs poorly at startup with maf plugged in

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
Phillieswon
Posts: 3
Joined: Mon Oct 21, 2019 2:04 pm
Year and Model: 2004 xc90 T6
Location: Atlanta

2004 xc90 T6 runs poorly at startup with maf plugged in

Post by Phillieswon »

Hello,
Codes p0102 idle control system rpm higher than expected; p0507 mass vol circuit low;p0442 Evap small leak

Put in brand new Bosch maf no improvement. If I plug in maf car wants to stall unless I stay on the gas. If I do this long enough the car will run fine but does it all over again when car turned off and started again.
Car runs; but sluggish with maf unplugged

Any input appreciated.
User avatar
SuperHerman
Posts: 1553
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 170 times

Re: 2004 xc90 T6 runs poorly at startup with maf plugged in

Post by SuperHerman »

Have you tried cleaning your throttle body?

As to the codes - did they all appear at the same time as your performance issues?
Phillieswon
Posts: 3
Joined: Mon Oct 21, 2019 2:04 pm
Year and Model: 2004 xc90 T6
Location: Atlanta

Re: 2004 xc90 T6 runs poorly at startup with maf plugged in

Post by Phillieswon »

Turned out to be evap lines were so degenerated the manifold was crushing them From the vacuum. Replaced them and now got a code for evap purge
User avatar
SuperHerman
Posts: 1553
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 170 times

Re: 2004 xc90 T6 runs poorly at startup with maf plugged in

Post by SuperHerman »

What vacuum lines did you replace? If I recall that valve is under the intake, near the starter. There are some hoses down there that could also be bad if you did not change them. There are posts on this repair. You can try to take out the valve and clean it - not sure if it will work, but worth a shot. Just spray some cleaner in there, once it dries give it some power and see if it makes any noise (actually do this before and after).
Phillieswon
Posts: 3
Joined: Mon Oct 21, 2019 2:04 pm
Year and Model: 2004 xc90 T6
Location: Atlanta

Re: 2004 xc90 T6 runs poorly at startup with maf plugged in

Post by Phillieswon »

Yes replaced the lines that plug into the purge valve (had a few Ts and check valves). I put in a new purge valve and still getting a code for valve. When i listen to that general area it still sounds like there is an vacuum leak noise every few seconds.

Turns out when I did the Pcv I did not clamp the tube onto the throttle body tight enough causing it to vibrate off. Once fixed,the Maf code went away😩. Should I hear the turbos spool up on this car because now I do. Could blocked pcv cause them to be silent?
User avatar
SuperHerman
Posts: 1553
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 170 times

Re: 2004 xc90 T6 runs poorly at startup with maf plugged in

Post by SuperHerman »

Evap Purge Valve see here: viewtopic.php?f=10&t=88390&p=516100&hil ... ve#p516100

Yes one hears the turbos. Blocked PCV should not impact turbos - they spin on exhaust directly.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post