IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2000 S-70 ABS module repair and install problem fix

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

zeke1256
Posts: 8
Joined: Wed Jul 01, 2015 10:08 am
Year and Model: S70 2000, 1995 850,
Location: Northwest CT
Has thanked: 0
Been thanked: 0
United States of America
zeke1256

2000 S-70 ABS module repair and install problem fix

Post by zeke1256 » Fri Oct 25, 2019 11:00 am

I had a bad ABS module on a 2000 S-70. ABS, Brake light, Speedo and odometer not working, all at once and CEL on saying no communication P0600. Midwest ABS repaired it. I had a hard time getting the plug to seat firmly in, as the plastic clip on the black cover guard had broke when I opened it. ABS, Brake light, CEL, wouldn't go off. Spoke to Matt at Midwest, he said to remove the sliders which were inside the blue large plug, these "sliders" are rectangular thin plastic pieces on each side of the long side of the plug inside the plug housing. I removed the black plastic guard from the hinge and slid out the sliders, towards the hinge side of the plastic guard. These are kinda hard to see but were there, Not sure what these "sliders" do but it may have something to do with the locking cover device. The plug then fit down and in nice and firmly and hold it down several seconds to let any air move out, Matt advised this also. I then put the guard back on, started car and everything back to normal, CEL went off after several miles of driving, No more issues. Hope this helps anyone with this same problem.



User avatar
BlackBart
Posts: 546
Joined: Sat Dec 10, 2016 5:03 pm
Year and Model: 2004 XC70 BlackBetty
Location: Montana
Has thanked: 38 times
Been thanked: 29 times
Sweden
BlackBart

Re: 2000 S-70 ABS module repair and install problem fix

Post by BlackBart » Fri Oct 25, 2019 12:30 pm

Impressive. My son and I are having the same issues in an '86 BMW project. We've gone through nearly every part - wheel sensors, tone rings, wiring, relays..... We think it's time to risk a used ABS module. I haven't found any suppliers with rebuilt.


ex-1984 245T wagon
1994 850T wagon
2004 XC70 wagon BlackBetty
Is it time for a 1964 122 wagon?

Post Reply