IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

HU-613 strange problem

How to integrate your phone into your Volvo's audio. Which speakers to buy to replace old ones. Recommended head unit brands and models... This is where we talk watts, ohms, GPS, iPod integration, component installation, tips, tricks and advice for making your Volvo's audio, video, ticket avoiding and mapping gadgets work better than ever... iPod, XM, GPS, DVD, Speakers, Amps, Radar Detectors
Yaworski
Posts: 36
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

HU-613 strange problem

Post by Yaworski » Fri Oct 25, 2019 12:37 pm

I didn't see this audio forum before, I could have posted my Yatour installation questions here.

However, I have a new question.

The HU-613 in my 2002 S6 does something odd on an irregular basis. Every now and then, it will jump from FM or CD or whatever to AM. Not vital to my life but it is irritating.

Any ideas? Just replace the radio?



User avatar
RickHaleParker
Posts: 3156
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 361 times
United States of America
RickHaleParker

Re: HU-613 strange problem

Post by RickHaleParker » Fri Oct 25, 2019 6:40 pm

Could be a sticky knob. Pull the Source knob off and look for gunk. Clean off any gunk.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Yaworski
Posts: 36
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: HU-613 strange problem

Post by Yaworski » Tue Nov 05, 2019 5:48 pm

RickHaleParker wrote:
Fri Oct 25, 2019 6:40 pm
Could be a sticky knob. Pull the Source knob off and look for gunk. Clean off any gunk.
It's not when I'm turning the knob. It just happens on its own. I'll be listening to a song and suddenly I'm listening to AM talk radio. No rhyme or reason.



User avatar
kranz
Posts: 225
Joined: Sat Jul 08, 2006 3:24 am
Year and Model: '98 V70 NA stick
Location: Atlanta
Has thanked: 0
Been thanked: 3 times
United States of America
kranz

Re: HU-613 strange problem

Post by kranz » Tue Nov 05, 2019 5:53 pm

Its common on those radios. It is the pots behind the knob. They get grimey and start to take on a life of their own. Turn the radio off and give the knob a workout turning it back and forth for a bit. It should postpone the problem for a while.


Les is more.

Post Reply