IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Intrument light + Bulb light problem Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Metallo
Posts: 219
Joined: Sun Jan 18, 2004 3:20 pm
Year and Model: XC 70 AWD 2.5 - 2006
Location: Canada
Has thanked: 1 time
Been thanked: 2 times
Canada
Metallo

Intrument light + Bulb light problem

Post by Metallo » Sun Oct 27, 2019 9:07 am

Hi guys,

I have a940 of 1997, Yazaki dashboard and I have an issue with one of the main 4 bulbs that light up the instrument (3W).

A picture will better clarify what I am talking about.

Image

The bulb will light up after about 45 min.

I took the multi-meter and verified both bulb + bulb holder, they are both OK.
As a second test, I removed one of the working bulb+holder assembly and tried if it would work when snapped in the not working bulb spot, no-go.

This leads me to conclude that the issue is not bulb-holder related, but something in the circuit of that assembly.
Obviously, when the thing heats up, after about 45 min., it works.

Can you help me from here?

Thank you!
Alex


Polar 940 Turbo SW - 1997
XC 70 AWD 2.5 - 2005
XC 70 AWD 2.5 - 2006

User avatar
RickHaleParker
Posts: 3110
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 355 times
United States of America
RickHaleParker

Re: Intrument light + Bulb light problem  Topic is solved

Post by RickHaleParker » Sun Oct 27, 2019 2:08 pm

Trace the paths. Look for loose screws, cracked printed circuits and defective solder joints. Any of which can open and close with thermal expansion.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Metallo
Posts: 219
Joined: Sun Jan 18, 2004 3:20 pm
Year and Model: XC 70 AWD 2.5 - 2006
Location: Canada
Has thanked: 1 time
Been thanked: 2 times
Canada
Metallo

Re: Intrument light + Bulb light problem

Post by Metallo » Sun Oct 27, 2019 7:20 pm

RickHaleParker wrote:
Sun Oct 27, 2019 2:08 pm
Trace the paths. Look for loose screws, cracked printed circuits and defective solder joints. Any of which can open and close with thermal expansion.
Hi there,

It was a defective solder under the rheostat, I have redone all the soldering and everything works as new.

Thank you,
Alex
These users thanked the author Metallo for the post:
CSDentonTX


Polar 940 Turbo SW - 1997
XC 70 AWD 2.5 - 2005
XC 70 AWD 2.5 - 2006

Post Reply