IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

No gas pedal after touching brakes?

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Post Reply
mrkauz
Posts: 3
Joined: Mon Oct 28, 2019 7:29 am
Year and Model: 2004 S60 2.5T
Location: KS - Kansas
Has thanked: 3 times

No gas pedal after touching brakes?

Post by mrkauz »

Hello,
I'm having an issue with my 04 S60. Basically as soon as you touch the brake pedal, the gas pedal no longer works. You can shut the car off and restart and it will work again, until touching the brake again. The car did have several codes relating to reduced engine performance (dash was reading reduced engine performance). The gas pedal and TPS was replaced with a used one, same issue. The throttle body was replaced with a used one same issue so put the original back on after cleaning it. Actually while the used one was on there the gas never worked. Does anyone have any idea what would cause this? I'm thinking maybe it's a electrical issue with wiring and I should just part the car out, but wanted to get some opinions before doing that. Any help would be greatly appreciated.
User avatar
abscate
MVS Moderator
Posts: 22493
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 376 times
Been thanked: 1176 times

Re: No gas pedal after touching brakes?

Post by abscate »

The wiring and connectors are on these cars are high quality and robust, if you don't see damage and/or corrosion, I would look away from that.

It sounds more like a software issue - the Electronic Throttle Body system (ETB, ETM, or ETS) actually shuts off the throttle pedal response if it detects brake pedal use - a safety feature combat the deadly AUDI 'Unintended acceleration" aka "Driver error" but it should return after a second or two from lifting the brake foot off the pedal. Maybe the brake switch is sticking? Check brake lights?
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
User avatar
oragex
Posts: 5019
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 99 times
Been thanked: 297 times
Contact:

Re: No gas pedal after touching brakes?

Post by oragex »

First time I read of such issue, so no clue but I would look at the CEM while there, your 04 was prone to water ingress - just with a flash light it will show if it has water marks on the unit. Not saying this is the problem, just another thing to check
mrkauz
Posts: 3
Joined: Mon Oct 28, 2019 7:29 am
Year and Model: 2004 S60 2.5T
Location: KS - Kansas
Has thanked: 3 times

Re: No gas pedal after touching brakes?

Post by mrkauz »

Thanks for the feedback. I will check brake lights and for water marks on the engine computer. I did remember i couple things I hadn't mentioned before about the brakes & also water. When you step on them, A motor comes on most of the time. Not exactly sure what that'd be besides maybe the ABS pump? Which probably should not be coming on. Any ideas on that? I did try removing all the fuses for the brakes (3 of them) and then tried. No pedal at all. Figured maybe if there was something shorting or had power that shouldn't maybe that would work, I was wrong. Also, when I got the car there was water under the carpets. Either the sunroof or the seals on the roof above the doors was leaking. They are pretty dry now. Is there anything under there that could have affected?
User avatar
abscate
MVS Moderator
Posts: 22493
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 376 times
Been thanked: 1176 times

Re: No gas pedal after touching brakes?

Post by abscate »

If you remove fuses the system gets unhappy as it then can't tell if you are braking or not - so it probably fails safe to limp mode.

You may even find the throttle system gets power from the brake line which fails safes it.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
xHeart
Posts: 2756
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 45 times

Re: No gas pedal after touching brakes?

Post by xHeart »

It reminds me of drive in CRUISE function, that is, depressing brake pedal will disengage CRUISE -- confused relay?
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240
User avatar
vtl
Posts: 1940
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 75 times

Re: No gas pedal after touching brakes?

Post by vtl »

I had 3 things failed in the brake system recently:

1. failed brake booster sensor. The car was dropping into 4th gear, no A/C, no boost
2. failed stop lights sensor. It was just complaining, no reduced engine performance
3. failed relay in CEM. BCM had no power at all. No ABS, no AWD, no odometer

Depending on what exactly you mean by "gas pedal no longer works" you may have 1.

But I would start with reading the codes using VIDA/DiCE.
05 XC70 265k, 16 XC60 45k, 19 Tundra 5k
cn90
Posts: 6834
Joined: Wed Mar 31, 2010 9:54 am
Year and Model: 2004 V70 2.5T
Location: Omaha NE
Been thanked: 153 times

Re: No gas pedal after touching brakes?

Post by cn90 »

The thread below may be useful for you...

2001 XC70 BLOWING FUSE#8 AND ACCELERATOR CUT OFF WITH BRAKE:

viewtopic.php?t=74353
2004 V70 2.5T 100K+
2005 XC90 2.5T 110K+
mrkauz
Posts: 3
Joined: Mon Oct 28, 2019 7:29 am
Year and Model: 2004 S60 2.5T
Location: KS - Kansas
Has thanked: 3 times

Re: No gas pedal after touching brakes?

Post by mrkauz »

Thanks for the tips and pointers. I check for water damage to the computer, didn't see any. My scanner said it had no codes but it's just a generic reader. I didn't want to tow to a dealership to gets codes read and with it being an electrical issue I just sold it. Didn't have the space to park it, just started a new job so there went my extra time to mess with it too. But again thanks for the help. I'm going to give him a link to this so your help may still get it working correctly.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post