IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Power rear liftgate closing on its own

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
caribvolvo1
Posts: 2
Joined: Tue Oct 29, 2019 6:57 am
Year and Model: 2010 XC60
Location: St. Kitts
Has thanked: 0
Been thanked: 0
St Kitts-Nevis
caribvolvo1

Power rear liftgate closing on its own

Post by caribvolvo1 » Tue Oct 29, 2019 7:18 am

I have a 2010 Volvo XC60 T6. It's a right-hand-drive I had to import from the Asian market, but it's otherwise a stock vehicle for North American standards. She's low milage (60,000). My chief issue is the power liftgate exterior handle has stopped working, and the liftgate falls once it has opened. I took a video of the action at this link: https://www.dropbox.com/s/0iso9cvef799s ... 6.mp4?dl=0

I have replaced the non-powered strut, that doesn't seem to be helping. The keyfob works fine. The motor engages and the door opens fully. Doesn't seem to be struggling. When the door is fully opened, it just starts to slowly close again, until it's about 2 inches from closed. Then it sounds like the motor re-engages as if I pushed the close button, and it slams. Really not sure what is causing it.

My biggest difficulty, I imported to St. Kitts - Tiny Caribbean island without much in the way of services. Basically, I am nowhere near a volvo dealership or authorized mechanic, that I am aware. I have access to parts, if I buy them and ship them in, so the remoteness is my biggest issue. If I knew what the problem was, I could order the parts and get a local mechanic to install them, but I'm at a loss, and nobody I have talked to is familiar enough with Volvos to diagnose.



aaronlife
Posts: 6
Joined: Tue Oct 29, 2019 3:58 pm
Year and Model: 2010 Volvo XC60
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
aaronlife

Re: Power rear liftgate closing on its own

Post by aaronlife » Tue Oct 29, 2019 4:01 pm

I have a similar issue only mine doesn't open on it's own again. It opens fine, and then slowly closes but doesn't latch. I replaced the strut on the right and it didn't help. If I open it, hold it open, and then press the button, it closes fine. So I assume there is a leak somewhere, losing pressure, air in the system, etc., but at $300 plus for the other parts, not sure what to start with. I'll post a new thread and see if a different title gets a response.



His400
Posts: 7
Joined: Tue Mar 03, 2015 8:47 pm
Year and Model: 2013 XC60r
Location: Upstate NY
Has thanked: 1 time
Been thanked: 0
United States of America
His400

Re: Power rear liftgate closing on its own

Post by His400 » Tue Nov 05, 2019 7:55 am

Last winter I had the internal spring bind on the shaft so it wasn't providing support... Scared the crap out of me when it unstuck with a bang. But the tail stayed up after that... Gotta get into it to polish and grease (heaviest you can find...)



caribvolvo1
Posts: 2
Joined: Tue Oct 29, 2019 6:57 am
Year and Model: 2010 XC60
Location: St. Kitts
Has thanked: 0
Been thanked: 0
St Kitts-Nevis
caribvolvo1

Re: Power rear liftgate closing on its own

Post by caribvolvo1 » Tue Nov 05, 2019 7:56 am

Was that the powered arm, or the supporting one on the other side?



Post Reply