IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Drivers side BLIS issue with Code B118C04

Help, Advice, Owners' Discussion and DIY Tutorials on the third generation Volvo V70 wagon and XC70 crossover, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

bans25
Posts: 2
Joined: Sun Nov 03, 2019 11:44 am
Year and Model: 2008 S80 T6
Location: Dover, NH
Has thanked: 0
Been thanked: 0
United States of America
bans25

Drivers side BLIS issue with Code B118C04

Post by bans25 » Sun Nov 03, 2019 11:48 am

Hi all,

I picked up a 2008 S80 T6 with 100K miles, I have one last problem I am trying to solve and looking for guidance.

Drivers side BLIS doesn't work and I get BLIS service needed. When I pulled the code I get B118C04

Does anyone know how to go about diagnosing this?

thanks much



User avatar
RickHaleParker
Posts: 3083
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 354 times
United States of America
RickHaleParker

Re: Drivers side BLIS issue with Code B118C04

Post by RickHaleParker » Tue Nov 05, 2019 3:39 am

It thinks the Left Camera Module (LCM) has a internal fault. It could be water ingress. Try cleaning the connector in the door.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

bans25
Posts: 2
Joined: Sun Nov 03, 2019 11:44 am
Year and Model: 2008 S80 T6
Location: Dover, NH
Has thanked: 0
Been thanked: 0
United States of America
bans25

Re: Drivers side BLIS issue with Code B118C04

Post by bans25 » Tue Nov 05, 2019 8:35 pm

I took the door panel off, green connector looks good. I also checked the green/white wire with an oscilloscope and there is serial communication to the Left hand camera, however I don’t know the protocol so not sure if the camera is responding.

Is there anything else I should look at before spending the $$ on a new camera?

Thanks much for the help
DCD39001-2889-43FE-95BB-25A3A1AF0E14.jpeg
55F533D9-C9E8-4CEA-95E0-8BFF9BC9FF5E.jpeg
You do not have the required permissions to view the files attached to this post.



User avatar
RickHaleParker
Posts: 3083
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 354 times
United States of America
RickHaleParker

Re: Drivers side BLIS issue with Code B118C04

Post by RickHaleParker » Wed Nov 06, 2019 7:23 pm

bans25 wrote:
Tue Nov 05, 2019 8:35 pm
Is there anything else I should look at before spending the $$ on a new camera?
Power, ground and data all three from the DDM, covers all the I/Os.
2019-11-06 (1).png
You do not have the required permissions to view the files attached to this post.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply