IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

[2013-XC60] USB port not functional

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
2013volvoxc60
Posts: 3
Joined: Sat Nov 02, 2019 12:06 pm
Year and Model: 2013 XC60
Location: Texas
Has thanked: 0
Been thanked: 0
United States of America
2013volvoxc60

[2013-XC60] USB port not functional

Post by 2013volvoxc60 » Mon Nov 04, 2019 4:17 pm

I've been trying to figure out why the USB port seemingly doesn't work. I checked some fuses, found one that was blown that corresponded to the 12 volt outlets, I was kind of hoping that'd fix it but I don't have the luck of the Irish.

I've tried a USB flash drive, formatted it to FAT32 and that didn't work. We have an old old ipod classic and tried that with the original cable and they didn't work, no sign of charging. Wife tried her iPhone and same thing.

Interestingly, my phone, a S10+ showed a charging sign but I had a notification saying to check and make sure it was properly connected on the phone. I'd speculate that the USB port isn't compromised then because my phone actually showed a connection.

But I'm stumped, not sure what it wrong with it. Any ideas?