IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2007 S60 Radio no power when ignition switch on [fuse 28 cem] Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

FarmallM51
Posts: 2
Joined: Wed Jun 05, 2013 4:36 am
Year and Model: 2001 S60
Location: Iowa
Has thanked: 0
Been thanked: 0
FarmallM51

2007 S60 Radio no power when ignition switch on [fuse 28 cem]

Post by FarmallM51 » Sun Nov 10, 2019 3:23 pm

I had to remove the radio from this car but when I reinstalled it there is no power to the violet wire on the green connector. As far as I can determine, this is the switched power supply. I do have power & ground to the red & brown wires on the same plug. Audio fuse #10 is fine. In my 2004 V70 I believe this wire is powered by fuse #15, but my fuses behind the headlight switch stop at #11. Any ideas how I can track this down or wire an alternative switched power?



User avatar
RickHaleParker
Posts: 3090
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 354 times
United States of America
RickHaleParker

Re: 2007 S60 Radio no power when ignition switch on  Topic is solved

Post by RickHaleParker » Mon Nov 11, 2019 4:46 am

Check fuse #28 in the CEM under the dash. That is where the violet wire comes from.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

FarmallM51
Posts: 2
Joined: Wed Jun 05, 2013 4:36 am
Year and Model: 2001 S60
Location: Iowa
Has thanked: 0
Been thanked: 0
FarmallM51

Re: 2007 S60 Radio no power when ignition switch on

Post by FarmallM51 » Mon Nov 11, 2019 7:17 am

THAT'S IT! Thanks. A bear to get to, but it was the one blown.



Post Reply