IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Where is the IAT sensor in 2007 S60 (typo was S70) Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

rjj100
Posts: 18
Joined: Thu Oct 24, 2019 9:54 pm
Year and Model: 2007 S60 2.5T
Location: Denver
Has thanked: 4 times
Been thanked: 0
United States of America
rjj100

Where is the IAT sensor in 2007 S60 (typo was S70)

Post by rjj100 » Fri Nov 22, 2019 1:16 pm

I would like to clean the intake air temperature sensor, I believe its temperature is reading higher than it should in a cold start in the AM.

Where is it located? Is it next to the intercooler on the drivers side or is that just a boost sensor? Is it below the intake manifold? A picture would be great.

Before you remind me, I have CRC QD (quick drying, safe for plastics, leaves no residue) electrical contact cleaner for the IAT sensor. I have ordered some CRC MAF cleaner for later use on the MAF sensor.

I have searched but not been able to locate this. One diagram showed it next to the MAF sensor.

My car is a 2007 Volvo S60 2.5T.
Last edited by rjj100 on Fri Nov 22, 2019 4:10 pm, edited 1 time in total.



User avatar
RickHaleParker
Posts: 3209
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 374 times
United States of America
RickHaleParker

Re: Where is the IAT sensor in 2007 S70  Topic is solved

Post by RickHaleParker » Fri Nov 22, 2019 2:30 pm

There is no 2007 S70 ...

This is for a 2007 S60.
2019-11-22 (1).png
You do not have the required permissions to view the files attached to this post.
These users thanked the author RickHaleParker for the post:
rjj100


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

rjj100
Posts: 18
Joined: Thu Oct 24, 2019 9:54 pm
Year and Model: 2007 S60 2.5T
Location: Denver
Has thanked: 4 times
Been thanked: 0
United States of America
rjj100

Re: Where is the IAT sensor in 2007 S60

Post by rjj100 » Fri Nov 22, 2019 4:08 pm

Thank you Rick! That S70 was a typo should have said S60 (which was correct stated in the body)

I saw that picture and then could not find the IAT sensor along pipe #6. I’ll look again.

The text (I hadn’t seen before) in this picture describes an alternate location, so I might have a chassis above 234500 that has the IAT combined with the boost sensor. That sensor has a bunch of wires. I must be very careful not to break it as I bet it is really expensive!

The temp is dropping and shadows getting long so I will quit for today.



User avatar
RickHaleParker
Posts: 3209
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 374 times
United States of America
RickHaleParker

Re: Where is the IAT sensor in 2007 S60

Post by RickHaleParker » Fri Nov 22, 2019 5:52 pm

rjj100 wrote:
Fri Nov 22, 2019 4:08 pm
I might have a chassis above 234500
The last six digits of the Vehicle Identification Number (VIN) is the chassis number. You can find the VIN on the title, the VIN tag in the corner of the Windshield or on the Identification plate under the hood.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

jimmy57
Posts: 6441
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 2 times
Been thanked: 196 times
jimmy57

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by jimmy57 » Fri Nov 22, 2019 6:22 pm

Except ECT is the determinant for cold start, IAT is only for high load monitoring for intercooler outlet. The left side outside mirror temp sensor is ECM ambient temp but again, it is not starting cold temp data. Is the car starting and dying when cold?



rjj100
Posts: 18
Joined: Thu Oct 24, 2019 9:54 pm
Year and Model: 2007 S60 2.5T
Location: Denver
Has thanked: 4 times
Been thanked: 0
United States of America
rjj100

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by rjj100 » Fri Nov 22, 2019 6:36 pm

Yes, I didn’t know that. Since my chassis number is even above 600,000, therefore the boost pressure and IAT sensors are together in the same physical part.

I will clean them, maybe tomorrow.



rjj100
Posts: 18
Joined: Thu Oct 24, 2019 9:54 pm
Year and Model: 2007 S60 2.5T
Location: Denver
Has thanked: 4 times
Been thanked: 0
United States of America
rjj100

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by rjj100 » Fri Nov 22, 2019 6:55 pm

Jimmy, the car runs great all the time. Cold, hot, doesnt matter. In fact, I just passed Colorado emissions testing today and all the test results were amazingly low, way way way lower than the limits.

My reason for cleaning is that the IAT temperature using my ZR13 scan tool shows the IAT temperature about 10 - 13 degrees F. warmer than my ambient temperature sensor in the right mirror as reflected in the console gauge and the ECM ambient temperature in the left mirror and seen by the same scan tool. I was having trouble getting the evap readiness test to clear until late this AM, and wondered if the car computer compared sensors to determine cold start. Clear as mud?

I’m saying that at cold start early in the AM the IAT temperature is 10 to 13 degrees warmer than both car ambient temperature sensors (left & right mirrors) and my temperature gauge at my house. Since a thermistor has a negative temperature coefficient, the thermistor and the plastic sensor housing probably have a bit of leakage from contaminants making the temperature read higher than it should.

I am not seeing any backfires like one might expect from a lean mixture. The temp diff must result in not too much leaning, and then later when the car warms up the leakage becomes less noticeable since the thermistor resistance has gone down.

Would you just advise leaving it be, not clean it?



User avatar
RickHaleParker
Posts: 3209
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 374 times
United States of America
RickHaleParker

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by RickHaleParker » Fri Nov 22, 2019 9:37 pm

rjj100 wrote:
Fri Nov 22, 2019 6:55 pm
My reason for cleaning is that the IAT temperature using my ZR13 scan tool shows the IAT temperature about 10 - 13 degrees F. warmer than my ambient temperature sensor in the right mirror as reflected in the console gauge and the ECM ambient temperature in the left mirror and seen by the same scan tool.
When? In the morning when the engine is dead cold and before starting, after it has been run that day, when it is running ... ect.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
abscate
MVS Moderator
Posts: 19131
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 229 times
Been thanked: 756 times
Trinidad & Tobago
abscate

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by abscate » Sat Nov 23, 2019 2:16 am

Yes, just leave it alone.

The mapping on your scanner could be wrong. If the charge air temperature is wrong enough to affect mixture control you would get trim code engine codes


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

rjj100
Posts: 18
Joined: Thu Oct 24, 2019 9:54 pm
Year and Model: 2007 S60 2.5T
Location: Denver
Has thanked: 4 times
Been thanked: 0
United States of America
rjj100

Re: Where is the IAT sensor in 2007 S60 (typo was S70)

Post by rjj100 » Sat Nov 23, 2019 6:31 am

Rick, yes, drop dead cold in the AM. Everything should be at the same temp.

Abscate, I slept on it and decided to not clean the IAT sensor at this time. “If it an’t broke, don’t fix it”.

I have other things to work on but that will be other topics if I need help.



Post Reply
  • Similar Topics
    Replies
    Views
    Last post