IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
31years
Posts: 9
Joined: Wed Oct 23, 2019 12:44 pm
Year and Model: 2009 XC90
Location: OR
Has thanked: 1 time
Been thanked: 0
United States of America
31years

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by 31years » Mon Nov 25, 2019 5:51 pm

gstallons wrote:
Mon Nov 25, 2019 5:20 pm
# 1 the outlet the coolant hose attaches to looks to be ribbed . Are these ribs in good condition ? If not replace it . Now I keep spring type hose clamps in stock for most all size heater , radiator hoses . I prefer them over anything else . These maintain CONSTANT tension . I've seen water outlet , t-stat housings and just about anything plastic carrying hot coolant fail over time . Do not be afraid to be liberal and replace anything you think is necessary .
Good luck !
I'll have to have a look at this, as I've never considered changing style from OEM. Constant tension makes sense, though.

As for the ribs, I'll have a good look at the unit when I remove it and let the forum know what I find.

Thanks for the input.



31years
Posts: 9
Joined: Wed Oct 23, 2019 12:44 pm
Year and Model: 2009 XC90
Location: OR
Has thanked: 1 time
Been thanked: 0
United States of America
31years

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by 31years » Mon Nov 25, 2019 5:54 pm

pgill wrote:
Mon Nov 25, 2019 5:37 pm
A link with some pictures

https://www.freel2.com/forum/topic32245.html

Let us know how it goes

Thanks

Paul
Paul, your link is a great resource - thanks for posting it.



jimmy57
Posts: 6442
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 2 times
Been thanked: 196 times
jimmy57

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by jimmy57 » Mon Nov 25, 2019 9:21 pm

LOL. Many years back when I first saw a 3.2 I6 at a pre-launch training event, A co-worker reached over and released the plastic air bleed line connector on that front and center metal cylinder head fitting. I was the unlucky one standing front and center of the just driven vehicle and it spit a good bit of warm coolant all over my shirt. Seeing that hose in your link made me laugh. I'm calling that SOB tomorrow and giving him some crap.



User avatar
oragex
Posts: 4430
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 89 times
Been thanked: 211 times
Contact:
Canada
oragex

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by oragex » Tue Nov 26, 2019 7:07 am

ouch, hopefully the coolant wasn't fully warmed
I've seen something similar at a junk yard. Random guy asked my to help him undo an intake on a Subaru. Quite complex work, plus there was this gas hose in the way and no apparent gas pressure release valve on that engine. Guy was thinking, since the car been sitting for several weeks (was already missing parts), just cut the gas hose and lift the intake. I warned him to no avail. I was wrenching a bolt on one side of the engine when all of a sudden I hear a pshhhht and the guy jumps back: got sprayed with gasoline directly into one eye - I urged him to run and wash his eye with water for several minutes. Hope he's fine by now



User avatar
pgill
Posts: 164
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 13 times
Been thanked: 27 times
United States of America
pgill

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by pgill » Tue Nov 26, 2019 9:38 am

Since we are talking about Clamps
clamp.jpg
My preference is the Type C clamp shown above.

However for the hose in question that this thread is discussing I just reused the Type B clamp and I reused the hose.

Don't worry about the plastic Ribs, when you buy a new Thermostat you will get new ribs.

In case you are wondering I haven't had a problem with this hose coming off on either of my 6 cylinder Volvo engines.

I suspect that your thermostat failed and that the failed Thermostat caused the over pressure condition that forced the hose off

Good Luck

Paul
You do not have the required permissions to view the files attached to this post.



gstallons
Posts: 56
Joined: Mon Dec 22, 2014 7:35 pm
Year and Model: 2004 XC90
Location: ky
Has thanked: 0
Been thanked: 0
United States of America
gstallons

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by gstallons » Sun Dec 01, 2019 4:39 am

I'm with xheart . The clamp looks too low on the hose and it promoted the hose to come off . The pics of the 3 types of clamps shown in the pics above , I prefer the spring ( constant tension ) type clamp for coolant hoses . I would install a new hose / clamp and use the clamp with a small amount of hose exposed at the end .



31years
Posts: 9
Joined: Wed Oct 23, 2019 12:44 pm
Year and Model: 2009 XC90
Location: OR
Has thanked: 1 time
Been thanked: 0
United States of America
31years

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by 31years » Sun Dec 01, 2019 10:22 pm

So, here's what I've found (and I'm not quite done yet, as I'm waiting on a couple of other parts to come in before I put everything back).

As you can see by this picture, the Tstat unit failed hard. The metal spring retainer is only held in place by about 1/16" of plastic on either side. The far right side has totally given way. Also note that the the smaller / top valve is now missing it's retention bulge - it was blown out when the hose disconnected.
IMG_20191128_134817.jpg
Both the hose and the clamp look to be in very good shape, although I am replacing both. The clamp was still in the correct place on the hose (there's a painted indicator to show you where it belongs), but I have no way to tell where it was along the valve itself.

On to the learning. #1 is that the Twist II lock is a total pain in the ass to disconnect. There appears to be a tool you can use, but a helper with a screwdriver above along with me + screwdriver underneath got the job done. The ring doesn't have to be move more than about 3/4", but what a distance that is! When moved, you'll hear a barely audible click. Pic below for locked and unlocked.

Locked
IMG_20191129_113005.jpg
Unlocked
IMG_20191129_112758.jpg
#2 is that the larger hose has a wire lock that is pretty easy to open - just slide a pick under the top of it and pull up. No issues on that one, once you know what to do.
IMG_20191129_120915.jpg
Thanks for all your help!

Brian
You do not have the required permissions to view the files attached to this post.



User avatar
pgill
Posts: 164
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 13 times
Been thanked: 27 times
United States of America
pgill

Re: Coolant Hose Blew off Thermostat? 2009 XC90 3.2 AWD, 99k miles

Post by pgill » Mon Dec 02, 2019 10:40 am

Brian,

Thanks for sharing the pictures.

The Thermostat on on 2010 S80 failed in the exact same location.

Note: for my 2008 LR2 (with the same Volvo 3.2) I replaced the Thermostat before it failed....but it did fail about 5 minutes after removal.
IMG_4918.JPG


Thermostat_2.jpg
Good Luck

Paul
You do not have the required permissions to view the files attached to this post.



Post Reply
  • Similar Topics
    Replies
    Views
    Last post