IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

96 850 non-turbo | vacuum issue after PCV job

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

jdw
Posts: 29
Joined: Sun Sep 20, 2009 10:12 pm
Year and Model: '96 855 '73 1800ES
Location: Berkeley CA
Has thanked: 0
Been thanked: 0
United States of America
jdw

96 850 non-turbo | vacuum issue after PCV job

Post by jdw » Sun Nov 24, 2019 12:18 am

I replaced the PCV system on my 96 850 non-turbo a while back. Keep getting 'large vacuum leak' CEL codes. Determined with a smoke tester that the top hose from coming from the PCV system doesn't seal well at the plastic connection into the air intake.

Attached picture shows the unit taken apart. The rubber seal (not in the picture) doesn't seem to be sufficient for a proper seal. The PCV line is OEM Volvo. How to resolve? Can I seal with RTV silicone?

Also noticed some leakage where the intake connects to the manifold.

Thank you.
JD | SF bay area | 96 855 GLT manual 210k miles
You do not have the required permissions to view the files attached to this post.



User avatar
erikv11
Posts: 9364
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 72 times
Been thanked: 226 times
United States of America
erikv11

Re: 96 850 non-turbo | vacuum issue after PCV job

Post by erikv11 » Sun Nov 24, 2019 12:39 pm

It looks like the car is missing the o-ring for the flame trap housing?

If you mean like this, for the RTV (or a tidier version of the same thing?), worked great for me as long as I owned the car I did it on:

Image


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

jdw
Posts: 29
Joined: Sun Sep 20, 2009 10:12 pm
Year and Model: '96 855 '73 1800ES
Location: Berkeley CA
Has thanked: 0
Been thanked: 0
United States of America
jdw

Re: 96 850 non-turbo | vacuum issue after PCV job

Post by jdw » Sun Nov 24, 2019 1:34 pm

The o-ring was installed but missing from my picture. The o-ring is not doing its job. I will try the RTV approach like shown on your your image. Thank you.



Post Reply
  • Similar Topics
    Replies
    Views
    Last post