IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

94 850 Wagon Max Fan Relay Hot, 4 speed not working

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
850heat
Posts: 1
Joined: Mon Nov 25, 2019 6:14 pm
Year and Model: 1994 850
Location: USA

94 850 Wagon Max Fan Relay Hot, 4 speed not working

Post by 850heat »

Hello,

My 94 850 wagon (with the MCC) has always worked on blower fan speeds 1-3, but never worked well on fan speed 4. By pulling the max fan speed relay from behind the glovebox and putting it back in, I can get speed 4 back for a short while, but usually after a few minutes it will stop. I've recently noticed that the relay gets very hot after these few minutes, plug 87 is a bit charred. Please see pictures.

Is there an obvious reason why its doing this? I tried replacing the relay but it did not solve the problem. Is there an issue with the resistor?

Cheers

Image
Image
Image
User avatar
RickHaleParker
Posts: 4709
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 604 times

Re: 94 850 Wagon Max Fan Relay Hot, 4 speed not working

Post by RickHaleParker »

Speeds 1, 2, & 3 are controlled by the resistor pack. Speed 4 switches on the relay and connects the fan motor directly to the Battery.

Check the relay socket, what condition is it in?

Probably overheat and burn like the relay terminal. You pull the relay out and reinsert, you get a good connection until it burns up again.
2019-11-26 (3).png
2019-11-26 (3).png (257.51 KiB) Viewed 101 times
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD.
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
User avatar
BEJinFbk
Posts: 3756
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 25 times
Been thanked: 56 times

Re: 94 850 Wagon Max Fan Relay Hot, 4 speed not working

Post by BEJinFbk »

Sounds like you need to replace both the relay and socket.
You may also have a worn blower motor issue that caused
your relay/socket problem. How old is that motor?
'98 V70 R - Well Equipped for Life Up North... ;)
dcarlson12
Posts: 508
Joined: Wed Jul 02, 2008 2:34 pm
Year and Model: 1997 850 T5
Location: Surrey, BC, Canada
Been thanked: 2 times

Re: 94 850 Wagon Max Fan Relay Hot, 4 speed not working

Post by dcarlson12 »

Did you ever solve this problem? If so, ????
Post Reply
  • Similar Topics
    Replies
    Views
    Last post