IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

S40 2.0T cuts injection

Help, Advice, Owners' Discussion and DIY Tutorials on S40 and V40. In this forum you'll find S40/V40-specific owners asking and answering questions on maintenance, ownership, repairs, tutorials and almost every do-it-yourself thing you can do to save money owning these Volvos.

1996 - 2004 S40
1996 - 2004 V40

shick95
Posts: 1
Joined: Sun Dec 01, 2019 4:00 pm
Year and Model: S40 2001 2.0T
Location: Cáceres, Spain
Has thanked: 0
Been thanked: 0
Spain
shick95

S40 2.0T cuts injection

Post by shick95 » Sun Dec 01, 2019 4:07 pm

Hi everyone, just joined, so happy to be a part of this. I own a s40 2.0T b4204T3, it practicaly runs perfect, the thing that is bugging me lately is that when the car hits around 4000rpm it cuts injection and the engine light comes on for like half a second, after that the engine keeps runing and the light goes out, still it hardly goes over that rev limit because it always has that problem. It also happened that the engine died a couple of times after revving it lightly, but it started right back.
So, i plugged my scan tool and found a couple of old codes, already cleaned and not appearing anymore.
The codes were related to the abs sensor and the crankshaft position sensor, both replaced and working perfectly. Also replaced the spark plugs a couple days ago.
So my uspect is that it may be a fuel problem, pressure regulator, maybe a lamba sensor or a vacuum leak. I have to dig a little more, but for now that is the situation, no new codes and the engine still runs fine, until about 4000rpm as i said
i'll keep you posted with any news about the problem.
I give you thanks in advance, tell me what you think or if anyone experienced his kind of issue



  • Similar Topics
    Replies
    Views
    Last post