IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2015 XC60 Brake System Failure + errors + Liftgate malfunctioning

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
amandamartin
Posts: 2
Joined: Tue Dec 10, 2019 12:17 pm
Year and Model: XC60 2015
Location: CA
Has thanked: 0
Been thanked: 0
United States of America
amandamartin

2015 XC60 Brake System Failure + errors + Liftgate malfunctioning

Post by amandamartin » Tue Dec 10, 2019 12:18 pm

Hey! I have a 2015 XC60 T6 with a little under 70k miles on it. Every now and then I will get the following errors while driving. Sometimes they well happen multiple times, sometimes not at all:

Brake System Failure - Stop Safely (this one happens the most often and when it does every warning light on the dash lights up (ABS, Check Engine, Tire Pressure, Seatbelt reminder, Gas, SRS, Brake, ESC, General warning, etc) and the mileage, mph, miles to empty, gph, and temperature also read '---' instead of the actual numbers and the radio, blinkers, and windshield wipers stop working for a period of time. I have tried to shut the car off and restart it when this error happens and the brake locks to where I cannot.
SRS Airbag Service Urgent
Alarm has been triggered
Volvo On Call Deactivated

I just took it in for service and they couldn't get the computer to recognize or read any of these errors. Lately the liftgate has also stopped working intermittently and requires manual opening and shutting (ie. the button doesn't auto close it) as well as making a repeating electronic skipping sound which sounds like it trying to close. Last night this happened for a few hours before stopping. Taking the fuses out did not stop the noise.

User avatar
RickHaleParker
Posts: 4514
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 575 times
United States of America
RickHaleParker

Re: 2015 XC60 Brake System Failure + errors + Liftgate malfunctioning

Post by RickHaleParker » Thu Dec 12, 2019 4:30 pm

Sounds like a random power interrupt. Check the main power for loose, dirty or shorting connections. It could be as simple as loose battery cables.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

amandamartin
Posts: 2
Joined: Tue Dec 10, 2019 12:17 pm
Year and Model: XC60 2015
Location: CA
Has thanked: 0
Been thanked: 0
United States of America
amandamartin

Re: 2015 XC60 Brake System Failure + errors + Liftgate malfunctioning

Post by amandamartin » Mon Dec 16, 2019 12:26 pm

Battery connections are brand new and seem fine.

PierreC
Posts: 31
Joined: Mon Dec 31, 2007 11:39 pm
Year and Model: 2016 V40 / 2011 XC60
Location: South Africa
Has thanked: 0
Been thanked: 0
South Africa
PierreC

Re: 2015 XC60 Brake System Failure + errors + Liftgate malfunctioning

Post by PierreC » Mon Dec 16, 2019 12:55 pm

I had a whole bunch of seemingly serious warnings and issues ... similar to some of the symptoms experienced by OP. These all disappeared when I replaced the battery. It seems that the Volvo electrical system is very sensitive to stable voltage around 12.8V+
Pierre

2016 V40 D4 VEA AT
2010 XC60 T6 AT
2015 V40 D3 (5 cylinder) AT [Gone]
2002 V70XC 2.4T AT - Elevate Stage 1 [Gone]
2007 S60 2.5T MT [Gone]
2002 S60 2.0T MT [Gone]
1996 850 GLT MT [Gone]

Post Reply
  • Similar Topics
    Replies
    Views
    Last post