IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Her first CEL

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
Sveedy
Posts: 58
Joined: Mon Nov 11, 2019 4:52 pm
Year and Model: 96 850 Turbo
Location: N. Arizona
Has thanked: 4 times
Been thanked: 9 times
United States of America
Sveedy

Her first CEL

Post by Sveedy » Fri Dec 13, 2019 5:22 pm

Well I took Sveedy on a long ( 200 mile ) drive down to the valley. She drove beautifully with no issues. When I went to leave about 5 hr later the CEL came on as soon as I started the engine. Idled smooth, drove ( flew ) back up the mountain with no problems and stopped to have the code read. " Misfire cyl #2 ". So my questions are could it have just misfired once at start up and then not again, and what might be the cause ? !30k miles w/ original plugs, wires cap etc...

Thanks for any ideas !

crlande
Posts: 287
Joined: Sat Jul 27, 2013 8:48 pm
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 1 time
Been thanked: 20 times
United States of America
crlande

Re: Her first CEL

Post by crlande » Fri Dec 13, 2019 7:01 pm

Yes. Reset the light and see if she spits again, if ever.

User avatar
abscate
MVS Moderator
Posts: 19999
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 272 times
Been thanked: 849 times
Trinidad & Tobago
abscate

Re: Her first CEL

Post by abscate » Fri Dec 13, 2019 7:32 pm

130k miles w/ original plugs, wires cap etc...

Thanks for any ideas !
Uh, that’s a good start. :)

Plugs cap rotor are 30k maintenance items, wires 100k items
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
RickHaleParker
Posts: 3577
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 434 times
United States of America
RickHaleParker

Re: Her first CEL

Post by RickHaleParker » Fri Dec 13, 2019 7:49 pm

Might be a leaking fuel injector on #2 that only shows up when the injector is saturated with heat. The fuel dumped on the top of the piston slews the Air/Fuel ratio for cylinder #2, goes away after the excess fuel burns off.
Last edited by RickHaleParker on Fri Dec 13, 2019 8:00 pm, edited 2 times in total.
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
Sveedy
Posts: 58
Joined: Mon Nov 11, 2019 4:52 pm
Year and Model: 96 850 Turbo
Location: N. Arizona
Has thanked: 4 times
Been thanked: 9 times
United States of America
Sveedy

Re: Her first CEL

Post by Sveedy » Fri Dec 13, 2019 7:58 pm

Thank you for your responses.
The original owner maintained it, up to a point, so maybe plugs have been replaced once or twice. She runs stupid smooth, so I know I'm not down a cylinder. As to the injector; I will take her out again tomorrow for run, but I don't pick up any odors and the performance is all there. This was the 5th or 6th long haul but the first light. I'll have it reset and see what happens.
Guess I know some of what she's getting for Christmas :)

User avatar
RickHaleParker
Posts: 3577
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 434 times
United States of America
RickHaleParker

Re: Her first CEL

Post by RickHaleParker » Fri Dec 13, 2019 8:03 pm

Sveedy wrote:
Fri Dec 13, 2019 7:58 pm
This was the 5th or 6th long haul but the first light. I'll have it reset and see what happens.
If this a leaking injector on #2, it might be difficult to replicate. It may require the injectors to be heat saturated and the engine to stop with all valves closed on cylinder #2. Closed valves prevents fuel vapors from escaping.

Would explain why it only shows up after a long run and only sometimes.

I replaced all six injectors on my 2.9L with remanufactured injectors. Did away with multiple misfires on start. Runs much better.
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
Sveedy
Posts: 58
Joined: Mon Nov 11, 2019 4:52 pm
Year and Model: 96 850 Turbo
Location: N. Arizona
Has thanked: 4 times
Been thanked: 9 times
United States of America
Sveedy

Re: Her first CEL

Post by Sveedy » Fri Dec 13, 2019 8:29 pm

Sending the injectors out for cleaning and flow testing is on my " to do " list. In the mean time I'll try rubbing her belly with new ignition parts and see how that goes.
Thanks again !

User avatar
Sveedy
Posts: 58
Joined: Mon Nov 11, 2019 4:52 pm
Year and Model: 96 850 Turbo
Location: N. Arizona
Has thanked: 4 times
Been thanked: 9 times
United States of America
Sveedy

Re: Her first CEL

Post by Sveedy » Fri Dec 13, 2019 8:43 pm

Well now you have thinking about the injectors. Any recommendations ?

User avatar
abscate
MVS Moderator
Posts: 19999
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 272 times
Been thanked: 849 times
Trinidad & Tobago
abscate

Re: Her first CEL

Post by abscate » Fri Dec 13, 2019 8:43 pm

At 130k miles, cleaning injectors is likely wasted

The misfire protocol sets the code based o a certain number of detected events under certain conditions, so it can easily be missed by the driver.

Open up the cap and rotor and show us pictures of the inside, close up on the metal parts

Then pull those plugs, keep them in order, check and report gaps,and show closeups of them

I bet those pictures are ugly
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
RickHaleParker
Posts: 3577
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 434 times
United States of America
RickHaleParker

Re: Her first CEL

Post by RickHaleParker » Fri Dec 13, 2019 8:52 pm

Sveedy wrote:
Fri Dec 13, 2019 8:43 pm
Well now you have thinking about the injectors. Any recommendations ?
Identify which injectors you have. I am seeing the red injectors for the 1996 850, OEM Bosch, remanufactured and flow matched, $40.00 for a set of 5 on ebay. Volvo use two different fuel injectors on the 1996 850 one type is fat the other is skinny. .
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply
  • Similar Topics
    Replies
    Views
    Last post