IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2004 XC70 transmission help needed

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

jorwood
Posts: 5
Joined: Sun Feb 11, 2018 9:37 am
Year and Model: 2004 XC70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jorwood

2004 XC70 transmission help needed

Post by jorwood » Mon Dec 16, 2019 1:46 pm

I have a 2004 Volvo XC70 with 125k miles. It's having the shift flare and hard down shift issues as well as going to "-" instead of shifting gears. I was researching the issue and found the same issues being fixed by replacing the inline solenoids and B4 servo cover. HOWEVER this seems to be on earlier XC70's. I'm trying to get a better understanding of what years exactly were effected. My build date is 04/03. I'm wondering if this fix would apply to mine or not? Any one know?

Any help would be appreciated.

User avatar
E Showell
Posts: 2967
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 9 times
Been thanked: 55 times
United States of America
E Showell

Re: 2004 XC70 transmission help needed

Post by E Showell » Mon Dec 16, 2019 2:11 pm

First step is to do several drain and fills of the automatic transmission fluid (procedure outlined on this site) with the correct specification ATF. I use Toyota Type IV, since it is the correct spec and significantly cheaper than the Volvo ATF. Toyota runs about $6/quart at my local dealer. Volvo is orders of magnitude more expensive. Do at least three drain and fills with a few miles between same and report back if you are still having problems.
Last edited by E Showell on Mon Dec 16, 2019 10:04 pm, edited 1 time in total.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic

jorwood
Posts: 5
Joined: Sun Feb 11, 2018 9:37 am
Year and Model: 2004 XC70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jorwood

Re: 2004 XC70 transmission help needed

Post by jorwood » Mon Dec 16, 2019 3:49 pm

I tried that already, seemed to help but not fix entirely. Now its back to the same old same old about 15k miles later

User avatar
E Showell
Posts: 2967
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 9 times
Been thanked: 55 times
United States of America
E Showell

Re: 2004 XC70 transmission help needed

Post by E Showell » Mon Dec 16, 2019 10:05 pm

I'd try another drain and fill.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic

jorwood
Posts: 5
Joined: Sun Feb 11, 2018 9:37 am
Year and Model: 2004 XC70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jorwood

Re: 2004 XC70 transmission help needed

Post by jorwood » Tue Dec 17, 2019 1:19 pm

I Just want to know if my transmission could possibly have bad solenoids based on it manufacture date.

User avatar
oragex
Posts: 4616
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 233 times
Contact:
Canada
oragex

Re: 2004 XC70 transmission help needed

Post by oragex » Tue Dec 17, 2019 2:02 pm

Mine had about the same miles on it. I did not had the flares, or the display issue. I had only some hard downshift and rough 2nd-3rd.

It seems to me there is a little too much behavior with your transmission at only 125K.
I'm going to guess you may have a different issue.
Two ideas:
1. Read online about how the MAF sensor influences the transmission shifting - I know, you will think I'm crazy but just google up
2. Your 2004 is known to get the CEM wet, which causes various electric troubles and may also trouble the transmission. Less probable it's your problem, but worth looking at the CEM with a flash light for any dried or wet traces of water.

jorwood
Posts: 5
Joined: Sun Feb 11, 2018 9:37 am
Year and Model: 2004 XC70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jorwood

Re: 2004 XC70 transmission help needed

Post by jorwood » Tue Dec 17, 2019 4:48 pm

Well the symptoms are identical to the linear solenoid and b4 servo issues of the previous years. So that seems the most likely. Just want to figure out the build dates affected before I drop the time and money into it. Then I'll start pursuing other potential problem sources.

User avatar
oragex
Posts: 4616
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 233 times
Contact:
Canada
oragex

Re: 2004 XC70 transmission help needed

Post by oragex » Tue Dec 17, 2019 5:10 pm

No one knows for sure the exact dates.. the solenoids are not bad, they just get clogged - this can happen on any years from 2001-2007 or later. The B4 cover was known to be bad for 2001-2002 but some found the issue on later years as well

jorwood
Posts: 5
Joined: Sun Feb 11, 2018 9:37 am
Year and Model: 2004 XC70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jorwood

Re: 2004 XC70 transmission help needed

Post by jorwood » Wed Dec 18, 2019 12:56 pm

thank you oragex I'm gonna take that info and run with it

Post Reply
  • Similar Topics
    Replies
    Views
    Last post