IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

04 p0300 after new coils etc

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

04 p0300 after new coils etc

Post by h20ham » Thu Dec 19, 2019 7:42 pm

It started missing, new timing etc.
Put a new injector as #4 was missing first. Probably Cam Follower.
Anyway, oddly. I get 1, 2, 3, 5 misfire codes. After I reset codes, engine runs a treat.
I know its #4 that has the follower issue. As the compression (wet test) is down.
I am wondering about ECM. Anyone know if ECM inputs corrupt ECM in this regards.
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Fri Dec 20, 2019 7:39 pm

As in, it has new coils and injectors.
Diode tests on all leads appear correct.

One of my old 850,s had a short on the blower fan which gave the p0300 multiple misses.
Looking at the wiring, Haynes. I dont see the same circuit. But its Haynes

Again, the compression test seems to indicate exhaust follower.
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Sun Dec 22, 2019 12:18 pm

So I gapped the plugs down to 27
No check engine light on, but it does go on an off every 5 minutes.
After codes were reset, it runs great.
The ECM or ecu whatever it called must have issues, hoping for some comments please
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Sun Dec 22, 2019 6:32 pm

Or if the battery has been disconnected for 20 min. It drives fine, for a drive cycle. Then, lags. No power. No codes.
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

User avatar
Roger_850T
MVS Moderator
Posts: 262
Joined: Tue Dec 31, 2013 11:55 am
Year and Model: 854T 1995
Location: Frederick MD
Has thanked: 0
Been thanked: 13 times
United States of America
Roger_850T

Re: 04 p0300 after new coils etc

Post by Roger_850T » Sun Dec 22, 2019 7:28 pm

With a P0300 trouble code, sounds like you're using a generic code scanner, not VIDA. P0300 is for random / multiple misfires.

I'm not sure what kind of circuit there is between the ignition and the blower fan on your 850.

For this one, I would look at common things for multiple misfires. And especially anything you just worked on.

Since this car has individual fuel injectors and individual coil packs, it's probably not them. Same with a single bad cam follower or valve.

I would look more for maybe an intake vacuum leak, allowing unmetered air into the intake system. That would cause misfires on all cylinders. Torn or broken intake hose, vacuum line split. On this engine I've had issues with rubber vacuum elbows failing, check those.

Probably wouldn't hurt to check the fuel pressure. Not individual injectors, but if the fuel pressure is low (or high) then all might have the same lean (or rich) misfire. They are pretty tolerant of fuel pressure out of range, but it's something that would cause issues on all 5 cylinders like what you're experiencing. You should be able to take a direct reading at the schraeder valve on the fuel rail.

If you have a chance, read it with VIDA. You might get a more specific code that will help you pinpoint the issue.

I hope this helps. Good luck!

Roger
'05 XC90 V8 140k
'95 854T 310k
'02 V70 159k
'03 S80 111k (crashed)
'93 945T 217k (gone to be parted out)
'87 245 300k+ sold, still going
'84 264 Diesel, RIP at 160k
'78 242 manual everything.
'73 P1800ES, fun until the rust set in...

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Mon Dec 23, 2019 12:10 am

Thanks, new pcv system en-route
For sure will address vacuum and boost hoses. Intake etc.
Guess i panic on the ECM ECU thing, understand that boost pressure and vaccume is metered and registered at computer

Was planning on adding Volvo to my Auto Enginuity, though i can not seem to find any conclusive reviews on AE
Yes, the Autel or BlueDriver only give generic. Ill bite the bullet in the am on the AE.

The reason I dont think it’s necessaryly boost or vac is the computer reset making things better short term...I’ve been wrong before

Also, the inter cooler flex rubber hose is soft. So i will address that too. Has anyone used an aluminum center section. Guess the (oil line?) sitting/rubbing on the passenger side is also of concern.

Further, the Xc has not been to a Volvo shop in 10 years...and the shop it has been being serviced at had VIDA but...

Another bit in the post is a ipd compressor bypass valve, as it has little or no boost after drive cycle

I will do a smoke test before pcv is updated
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Thu Jan 09, 2020 12:04 pm

Installed new vacuum, pcv, turbo control lines etc.
Still getting #4
So, while in there. To do the cam followers, on all 20. Valve stem seals, anything else I should consider.

Kind Regards
Jim
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

h20ham
Posts: 71
Joined: Sat Feb 23, 2013 10:06 pm
Year and Model: 1998 xc
Location: bc
Has thanked: 0
Been thanked: 0
Canada
h20ham

Re: 04 p0300 after new coils etc

Post by h20ham » Fri Jan 10, 2020 2:39 pm

Fuel pressure, at schrater test port. 55 at idle
55 at 6000 rpm
Clearing codes, does not seem to remedy rough idle.
New injector seats. New plugs. New coils.
Now, #5 is acting up again.
Changed oil twice. 5 30
Added seafoam before first change to oil. And gas.
It always takes a drive cycle to get to rough idle. And 300, 304, 305 now appear all the time.
I have noticed only once. The dashboard illumination darkens when turning fan or lights off or on.
So, I think I should get some new diodes for the alternator. Any recommendations as to supply of alternator rebuild kit?
Maybe i am barking up the wrong tree. My early obd code clearing attempts, were drivability increased with clearing codes. Also the rough idle disappeared, if only for a short time. Or until the next drive cycle.
I should add a boost gauge as boost pressure seems it disappears. But maybe that is the limp mode, rather than any boost problem. Again, after battery disconnected for 30 min. Boost is fine, until check engine light (which does not always come on, but flashes. Then codes present) even without the engine light on?
68 125 b18 4 speed
72 164e b30 5 speed
79 242 16v 5 speed
84 744 T 5 speed
86 745 T 5 speed
88 765 T aw71
91 745 T 5 speed
95 965 T shift controller in progress
05 xc90 rough idle

Post Reply
  • Similar Topics
    Replies
    Views
    Last post