IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

2004 XC90 OBD II port stopped working

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
brunocerous
Posts: 318
Joined: Tue Oct 27, 2015 5:24 pm
Year and Model: 1998 V70
Location: Maplewood, New Jersey
Has thanked: 55 times
Been thanked: 7 times

2004 XC90 OBD II port stopped working

Post by brunocerous »

Hi all,

The OBD II port on my 2004 XC90 stopped working properly. While I probably wouldn't care so much normally, I use a Metromile tracker (auto insurance priced per mile), and without a signal, they'll charge me as if I'm driving 150 miles per day.

I checked the interior fuses and tried a Wi-Fi OBDII reader that also doesn't connect properly.

Is there anything else I should be looking for?

Any help would be greatly appreciated.

cheers,
Bruno
2004 XC90 AWD
2000 V70, base, MT, 'The Silver Bullet'
1998 V70, base, AT, 'Blue Steel'
1998 V70 T5, AT, project
1999 V70 XC AWD, AT (RIP)
1998 S70 T5, AT (RIP)
wanderdüne
Posts: 208
Joined: Thu May 18, 2017 5:24 pm
Year and Model: 2004, 2006 XC90 2.5T
Location: kitchen
Has thanked: 4 times
Been thanked: 40 times

Re: 2004 XC90 OBD II port stopped working

Post by wanderdüne »

Check fuse #22 in the panel at the left side of the dashboard. Refer to page 145 (Maintenance) in this https://volvo.custhelp.com/app/manuals/ ... /om_id/635 manual.
brunocerous
Posts: 318
Joined: Tue Oct 27, 2015 5:24 pm
Year and Model: 1998 V70
Location: Maplewood, New Jersey
Has thanked: 55 times
Been thanked: 7 times

Re: 2004 XC90 OBD II port stopped working

Post by brunocerous »

Thanks, wanderüne. I've gone through fuse 22, as well as every fuse under the hood, in the cabin, and in the trunk. Everything checks out, but I'm still not getting a steady connection. (It did connect properly once with ignition in 'on' position but engine off.)

Also, strangely, the moonroof stopped working. That fuse also looks OK. Any ideas would be welcome!
2004 XC90 AWD
2000 V70, base, MT, 'The Silver Bullet'
1998 V70, base, AT, 'Blue Steel'
1998 V70 T5, AT, project
1999 V70 XC AWD, AT (RIP)
1998 S70 T5, AT (RIP)
Post Reply
  • Similar Topics
    Replies
    Views
    Last post