IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Intermittent "bulb failure" rear fog light, but bulb is good/works!

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
silentcircuit
Posts: 2
Joined: Fri Jan 03, 2020 8:27 am
Year and Model: 2006 S40 T5 AWD
Location: Charleston, SC
Has thanked: 0
Been thanked: 0
United States of America
silentcircuit

Intermittent "bulb failure" rear fog light, but bulb is good/works!

Post by silentcircuit » Fri Jan 03, 2020 8:38 am

Proud new owner of a well taken care of 2006 S40 T5 AWD with only 103K miles. Unfortunately, it has developed a minor electrical gremlin.

Primarily while accelerating or just maintaining speed the "Info" light on the dash will flash randomly, accompanied by the "Bulb failure, rear fog light" warning in the info display. Pressing the "OK" button doesn't get rid of it for long because the fault recurs, often within seconds. It almost always clears itself when you brake, so it's clearly something loose / rubbing / whatever.

I've seen mention on forums that this is a known issue with this generation of S40 / something others have experienced, but it's just mentioned in passing, no solutions being offered.

Bought this car a couple days ago, zero other issues with it, but this has gotten progressively worse and more annoying -- pretty sure I have an intermittent short or bad connection somewhere.

The flashing is annoying and distracting. My temporary solution is to pull the (working) bulb so I can just clear the warning once on start-up, but I don't like to drive around with things wrong with my cars, minor as this is.

Is there somewhere I should start looking, specifically, or am I going to have to trace the whole **** line back to source?

Thanks for any help or suggestions.

silentcircuit
Posts: 2
Joined: Fri Jan 03, 2020 8:27 am
Year and Model: 2006 S40 T5 AWD
Location: Charleston, SC
Has thanked: 0
Been thanked: 0
United States of America
silentcircuit

Re: Intermittent "bulb failure" rear fog light, but bulb is good/works!

Post by silentcircuit » Fri Jan 03, 2020 11:08 am

Pulling and replacing the bulb and the connections on the associated assembly a few times seems to have cleared the fault for now, but I doubt this is a long term solution. Will update here if it comes back, and still looking for suggestions in the meantime. Thanks.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post