IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Transmission T6

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
tank1331
Posts: 2
Joined: Tue Jan 07, 2020 10:09 am
Year and Model: 2005 XC 90
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
tank1331

Transmission T6

Post by tank1331 » Tue Jan 07, 2020 10:12 am

I am hoping someone here can help me diagnose a problem with my XC90 T6. I jsut pruchased the vehicle with 140k (miles) on it. The vehicle slips or "studdors" when in drive but only at take off. When i use the manual mode and shift myself it has no problem. I know these transmissions are junk but it doesn't make sense to me that the transmission is bad when it works in manual and not in drive. Any help or explanation would be hugely appreciated.

User avatar
RickHaleParker
Posts: 3555
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 433 times
United States of America
RickHaleParker

Re: Transmission T6

Post by RickHaleParker » Tue Jan 07, 2020 12:39 pm

I got the same truck. When I first got it the shifting was all over the map, I had to manual shift it all the way home. Replaced the defective starter battery and a lot of errors cleared up, including the shifting. Check the battery condition, low voltages can cause all kinds of errors.

A Vida-DiCE clone would be a good investment. It will pay for itself in one avoided misdiagnosis .
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

tank1331
Posts: 2
Joined: Tue Jan 07, 2020 10:09 am
Year and Model: 2005 XC 90
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
tank1331

Re: Transmission T6

Post by tank1331 » Tue Jan 07, 2020 2:10 pm

Thank you that’s a much easier fix than what I was starting to think from everything I have read on line....I should mention it is a 2005 xc90 t6

User avatar
SuperHerman
Posts: 1337
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: Transmission T6

Post by SuperHerman » Tue Jan 07, 2020 2:26 pm

Two things - 1) RickHaleParker is right in that Volvos act very strange when power is low. First place to start.

2) The transmission is GM - so besides the Volvo power side it behaves like the transmission of a similar year Impala (to name one of many). So expand your reading to include other cars that share the same transmission.

Check your fluid level and condition - dip stick is near the strut tower - cylinder #6 on driver side. Should have a yellow pull end.

katman96
Posts: 2
Joined: Sun Jan 26, 2020 3:36 pm
Year and Model: 2004 XC90
Location: Connecticut
Has thanked: 0
Been thanked: 0
United States of America
katman96

Re: Transmission T6

Post by katman96 » Sun Jan 26, 2020 3:44 pm

I am experiencing a somewhat similar issue with my 04 XC90. It is slipping in first gear, while the other gears seam fine. I have 190K on it and its always been (very) well maintained. I wouldnt be opposed to putting some money into this but Im not sure where do draw the line. Has anyone experienced this? Am i crazy for wanting to repair it?

User avatar
RickHaleParker
Posts: 3555
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 433 times
United States of America
RickHaleParker

Re: Transmission T6

Post by RickHaleParker » Mon Jan 27, 2020 3:58 am

katman96 wrote:
Sun Jan 26, 2020 3:44 pm
I am experiencing a somewhat similar issue with my 04 XC90. It is slipping in first gear, while the other gears seam fine.
What does the Transmission Fluid look like? Fluid Color? How many miles on the Transmission filter?



Long sliding shifts:

"This problem is one that most 4T65E transmissions experience sooner or later. The factory design did not allow enough compensation for wear- so the result is normally poor shift feel and long or lazy shifts, especially the 1-2 shift which leads to eventual failure. The 2nd clutch clearance from the factory is set very loose and as wear occurs this will grow and make the shift feel worse. General wear inside the transmission also causes apply pressure to drop with age so these two problems add up and this is one area that does not need to be short handed on pressure.

The 1999-2002 models are also well known for pressure control solenoids prematurely failing and can cause low line pressure that the TCM cannot control. Often times if the transmission has low mileage and is in good internal condition you can upgrade the factory 1-2 and 2-3 accumulator parts with ones from a Transgo Shift Kit and this is a good aid to help get clutches to apply when they should. A shift kit does not make up for excessive clutch clearances but does speed up the time the clutch will apply".
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

katman96
Posts: 2
Joined: Sun Jan 26, 2020 3:36 pm
Year and Model: 2004 XC90
Location: Connecticut
Has thanked: 0
Been thanked: 0
United States of America
katman96

Re: Transmission T6

Post by katman96 » Mon Jan 27, 2020 2:07 pm

The fluid looks very good, I keep on top of that.I do fairly regular fluid changes. The filter was changed 40K ago, I dont want to set myself up for a transmission change out if theres another way obviously. The car otherwise is in awesome shape Ive kept on top of everything and I would hate to get rid of it.

User avatar
SuperHerman
Posts: 1337
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 135 times
United States of America
SuperHerman

Re: Transmission T6

Post by SuperHerman » Mon Jan 27, 2020 8:08 pm

Two items: 1) From my experience the fluid and filter will tell the story if your clutch discs are worn. You have to look at the filter, because if it is doing its job correctly it will filter and trap the burnt disk material. On my last failure the oil was clear looking at the stick, but the filter was clogging from the burnt out disks. You may have another issue, but if you have to remove the transmission it makes sense to do a complete rebuild.

2) If you shop around you should be able to find a rebuild turn key for $2500-3000 - that is with install. All new updated transmission parts, solenoids and torque converter with a 24/month unlimited mile warranty cost me just under $3,000.00. The transmission comes out like any other car for the most part and the rebuild parts are common GM (with a Volvo kit) - it is an easy rebuild for any busy tranny shop.

The way to look at it - price out your rebuild, assuming in your area you can get it fixed for $3,000.00 - what other car can you get of equal quality for that price? Maybe throw a few hundred more to get all the seals, including rear main seal, replaced while they are there.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post