Amazon Black Friday deals
IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

MAF Sensor

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
abscate
MVS Moderator
Posts: 23205
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 412 times
Been thanked: 1270 times

Re: MAF Sensor

Post by abscate »

You will faulting lean codes if you are getting t\oo much air , or if the MAF

Have- a look at the fuel trims and see what your engine is trying to correct, that will guide to you to the fault.

Finding vacuum leaks is much easier when you KNOW you have them.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
User avatar
SonicAdventure
Posts: 383
Joined: Fri Jul 03, 2015 9:43 am
Year and Model: 1996 850 wagon
Location: America
Has thanked: 32 times
Been thanked: 8 times

Re: MAF Sensor

Post by SonicAdventure »

LOL speaking of MAFs...1996 non turbo 850 wagon -

Went out for a Sunday drive a few days ago. About 20 miles from my house; I decided not to bring my phone.

Stopped at a gas station for gas, got some coffee, come out and the car would not idle right AT ALL. Up and down, revving, chugging the whole bit. Stalled several times also. Got it going again and pulled from the gas pump to the side of the station where I was out of the way. Let it sit a minute, thinking maybe I was having recurring issues with my fuel pump or relay. Disconnected battery and swapped out my fuel pump relay just to see. Sure enough, it started right up, but then it stalled again. This time, it threw a code: P0102 low MAF voltage. I unplugged the MAF cable and it sort of started OK, ran crappy for about 10 seconds then stalled. Next time I started it up it seemed to run OK.

Didn't really want to make the trip, but I said my prayer and gave it a shot...I figured every mile I got closer to home was a few bucks off the tow bill, but I would have been walking to the nearest farmhouse to make the phone call. Car made it home no issues, although the idle didn't seem 100% even. Let it sit overnight and the next day I swapped the MAF with the one from my old 98 n/a which never threw a MAF code. Car started right up and has been running fine since.

Not sure what throws the low voltage or if that can be "cleaned" away. Any way, if there is a way to repair this aspect of these sensors I would be willing to try.

Best of luck everyone -

Sonic
ToriWhite
Posts: 112
Joined: Thu Sep 15, 2016 11:00 pm
Year and Model: 1996 850
Location: Davis
Has thanked: 18 times
Been thanked: 3 times

Re: MAF Sensor

Post by ToriWhite »

At least before swapping MAF ($300!!!) its worth giving it a shot with some MAF cleaner.. you never know!
User avatar
SonicAdventure
Posts: 383
Joined: Fri Jul 03, 2015 9:43 am
Year and Model: 1996 850 wagon
Location: America
Has thanked: 32 times
Been thanked: 8 times

Re: MAF Sensor

Post by SonicAdventure »

ToriWhite wrote: Wed Jan 15, 2020 1:13 pm At least before swapping MAF ($300!!!) its worth giving it a shot with some MAF cleaner.. you never know!
The part I swapped came from out of a parts bin; removed from my old car last summer. I saved the one that "failed" and I may test it someday, but for now I shelved it.
User avatar
erikv11
Posts: 10041
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 124 times
Been thanked: 348 times

Re: MAF Sensor

Post by erikv11 »

Get a junkyard MAF, $20-30, makes it really cheap and easy to troubleshoot or bail you out if the existing one fails. Must be Bosch for 98 and earlier.
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k
ferocity02
Posts: 166
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Been thanked: 10 times

Re: MAF Sensor

Post by ferocity02 »

misha wrote: Tue Jan 14, 2020 2:04 am What spark plugs the car have?
Volvo plugs or something else?
Spark plug gap is critical on turbo cars.
They don't like fancy plugs....just Volvo ones for turbo engines or cheap copper plugs(NGK or Bosch) properly gapped.
It has cheap copper plugs. I cannot recall the PN or set gap, so I bought some Bosch 9755 plugs and will ensure they are gapped to 0.028".
ferocity02
Posts: 166
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Been thanked: 10 times

Re: MAF Sensor

Post by ferocity02 »

misha wrote: Tue Jan 14, 2020 2:04 am What spark plugs the car have?
Volvo plugs or something else?
Spark plug gap is critical on turbo cars.
They don't like fancy plugs....just Volvo ones for turbo engines or cheap copper plugs(NGK or Bosch) properly gapped.
It was indeed the plugs. I replaced them with Bosch 7955 FR7DC+ gapped to 0.028" and misfire seems to be gone.

I will not be replacing the MAF sensor at this time.
User avatar
misha
Posts: 4537
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 63 times
Been thanked: 166 times

Re: MAF Sensor

Post by misha »

Seems to be gone or gone?
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS
Post Reply
  • Similar Topics
    Replies
    Views
    Last post