IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

No heat and little air coming from the vents

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Rvolvos
Posts: 112
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 37 times
Been thanked: 6 times

No heat and little air coming from the vents

Post by Rvolvos »

On our 2006 Volvo V70, there is little heat and air coming from the vents.
I have checked coolant reservoir level, temperature of the hoses to radiator does not overheat and warms up.
Checked the temperature of the hoses going to and from the heater core. Both are warm.
Cleaned the cabin filter, the fan does make a lot of noise when turn on max. But still no large flow.
Cleaned the cc temp sensor, used a vacuum cleaner to draw out dust
Hooked up VIDA;
Verified blend door motor request and actual value, they match
Interior temperature is reporting 20 degrees C , a bit too high.
Fan speed
Calibrated the CCM. No fault codes stored.
Cleared all codes ( ccm-0060, 0063, 0061,0062,0064 where present) but did not return, did did not resolve the issue.

I am planning on cleaning the fan behind the temperature sensor and see if any thing on top of the blower fan is blocking the flow. Other than that I am running out of ideas and looking for other suggestions.
Attached the codes before clearing.
Attachments
ED7DCB28-1DA9-4DC8-83EF-477AC9FFE1C6.jpeg
2006 XC70 2.5T 190k
2006 V70 2.5T 152k
2011 C30 T5 AW55-50SN 99k
2011 C30 T5 M66 66k
User avatar
chris11211
Posts: 76
Joined: Tue Feb 26, 2019 4:44 pm
Year and Model: 2006 s60 2.5T
Location: Brooklyn, NY
Has thanked: 6 times
Been thanked: 11 times

Re: No heat and little air coming from the vents

Post by chris11211 »

No cleaning won't help if you can put it on max heat and you still get nothing. You can open up all of the plastic pieces that goes below the shifter and below the steering wheel and glovebox, set key to position II and mess with the climate control to actually look at the mechanism to see if it moves with your input. (ex: max cold/hot) Otherwise, it looks like you might need a new heater core.

Not a hard job at all, all you need is a t25 torx, new coolant, and silicone lubricant. Hardest part is to get everything out of the way, especially the two hoses that should be uninstalled from the firewall.
Rvolvos
Posts: 112
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 37 times
Been thanked: 6 times

Re: No heat and little air coming from the vents

Post by Rvolvos »

Thanks much for your response. You think it is clogged up? Both hoses where warm indicating a coolant flow.
I will take look at the linkage of the blend doors.
2006 XC70 2.5T 190k
2006 V70 2.5T 152k
2011 C30 T5 AW55-50SN 99k
2011 C30 T5 M66 66k
User avatar
Rattnalle
Posts: 1674
Joined: Fri Sep 01, 2017 2:10 am
Year and Model: 2004 V70 2.5T
Location: Sweden
Has thanked: 20 times
Been thanked: 124 times

Re: No heat and little air coming from the vents

Post by Rattnalle »

Is the air flow poor with the system set to max cold as well? If only when trying to get heat I agree that a clogged heater core sounds reasonable. If always poor the blockage is somewhere else.
User avatar
abscate
MVS Moderator
Posts: 22576
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 377 times
Been thanked: 1182 times

Re: No heat and little air coming from the vents

Post by abscate »

Are those hoses warm or too hot to touch? They should be the latter if the core is in full flow.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
Rvolvos
Posts: 112
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 37 times
Been thanked: 6 times

Re: No heat and little air coming from the vents

Post by Rvolvos »

abscate wrote: Sun Jan 19, 2020 11:51 pm Are those hoses warm or too hot to touch? They should be the latter if the core is in full flow.
I have measured with an infrared thermometer the upper coolant hose 170F and both hoses going to the heater core. Left hose 130F Right hose 170F. I am assuming there is flow and heat exchanged at the core, due to the temperature drop.
2006 XC70 2.5T 190k
2006 V70 2.5T 152k
2011 C30 T5 AW55-50SN 99k
2011 C30 T5 M66 66k
Rvolvos
Posts: 112
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 37 times
Been thanked: 6 times

Re: No heat and little air coming from the vents

Post by Rvolvos »

Rattnalle wrote: Sun Jan 19, 2020 11:30 pm Is the air flow poor with the system set to max cold as well? If only when trying to get heat I agree that a clogged heater core sounds reasonable. If always poor the blockage is somewhere else.
There is definitely more flow when the temperature is set to cold. I have removed the cabin filter to rule out a clogged filter.
2006 XC70 2.5T 190k
2006 V70 2.5T 152k
2011 C30 T5 AW55-50SN 99k
2011 C30 T5 M66 66k
Rvolvos
Posts: 112
Joined: Sun Apr 01, 2018 6:32 pm
Year and Model: 2006 xc70
Location: California
Has thanked: 37 times
Been thanked: 6 times

Re: No heat and little air coming from the vents

Post by Rvolvos »

Also removed the panels left and right from bottom of the dash and shifter. I can see the linkages work when changing direction of flow and temperature.
It looks like a clogged airflow trough the heather core?
Strange there has been a filter in cabin filter in place.
2006 XC70 2.5T 190k
2006 V70 2.5T 152k
2011 C30 T5 AW55-50SN 99k
2011 C30 T5 M66 66k
User avatar
vtl
Posts: 1948
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 75 times

Re: No heat and little air coming from the vents

Post by vtl »

Try to calibrate CCM first. Can be done in VIDA that you have.

What has happened to the car? Why does it have so many communication failures? Is it a weak battery and long starter cranking? That can brick the car, FYI.
05 XC70 265k, 16 XC60 45k, 19 Tundra 5k
User avatar
chris11211
Posts: 76
Joined: Tue Feb 26, 2019 4:44 pm
Year and Model: 2006 s60 2.5T
Location: Brooklyn, NY
Has thanked: 6 times
Been thanked: 11 times

Re: No heat and little air coming from the vents

Post by chris11211 »

I'd definitely say it's clogged.I've tried most of the stuff you did; even did a heater core flush a few times to no avail.

Not sure how far north you are, or if you got a warm garage to do this. But you are gonna have to do a coolant flush if you didn't already; a new heater core, two pipe clamps, and two o-rings for it.

https://www.fcpeuro.com/products/volvo- ... 0-9171503b
https://www.fcpeuro.com/products/volvo- ... e-30767252
https://www.fcpeuro.com/products/volvo- ... my-8693268
https://www.fcpeuro.com/products/volvo- ... vo-9434699

Id also follow peppermint's video on the heater core, and I'd add that you should spray silicone lube on the o-rings and see if you can disconnect the pipes from the firewall. Not a hard job at all.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post