IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2007 XC70 start problem

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Mpdog37
Posts: 2
Joined: Sat Feb 08, 2020 2:34 pm
Year and Model: 2007 XC70
Location: Naples Fl
Has thanked: 0
Been thanked: 0
United States of America
Mpdog37

2007 XC70 start problem

Post by Mpdog37 » Sat Feb 08, 2020 2:41 pm

Strange starting issue with my 2007 XC70, turn key to start, cranks 3 times then stops, no start, turn key off try to start again, cranks 3 times then stops... any ideas why this could happen.

User avatar
yagger
Posts: 210
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 2 times
Been thanked: 8 times
Belarus
yagger

Re: 2007 XC70 start problem

Post by yagger » Sun Feb 09, 2020 1:55 pm

Not enough info. Show please errors from VIDA.
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

User avatar
oragex
Posts: 4607
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 233 times
Contact:
Canada
oragex

Re: 2007 XC70 start problem

Post by oragex » Sun Feb 09, 2020 2:07 pm

Same when jump starting ?
May also see the wires at the starter, also this one at the rad fan viewtopic.php?f=9&t=92688

Mpdog37
Posts: 2
Joined: Sat Feb 08, 2020 2:34 pm
Year and Model: 2007 XC70
Location: Naples Fl
Has thanked: 0
Been thanked: 0
United States of America
Mpdog37

Re: 2007 XC70 start problem

Post by Mpdog37 » Sun Feb 09, 2020 4:26 pm

No diagnostic at this point, apartment mechanic, so can’t really disassemble much, got some stink eyes, checked grounds, and starter wiring, battery went dead, tried jumpbox, same thing, tried new battery, same thing, crank pulley marked and turning, compression seems good, doesn’t seem immobilized, I don’t know, will seek diagnostic and see what comes up... I’ve had (5) 122’s, and 3 v70’ wagons, this is first 21st century, and its over my head, give me a 4 banger and I’m all good, Lol....

Post Reply
  • Similar Topics
    Replies
    Views
    Last post