IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

XC70 2001 with rough idle but otherwise works great

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

shodanx
Posts: 14
Joined: Mon Dec 10, 2018 8:04 pm
Year and Model: xc70 2001
Location: New York
Has thanked: 0
Been thanked: 0
Canada
shodanx

XC70 2001 with rough idle but otherwise works great

Post by shodanx » Sun Mar 15, 2020 5:22 pm

Hi,

I have been driving this 650000km V70 XC 2001 since I bought it november 2019.
I fixed a couple things and it still has some issues but the more persistent one has been rough idling.

I replaced all coils and spark plugs this appears to have had little change

I replaced the timing belt/ tensionner/ water pump due to severe oil leakage at camshaft oil seal (seal blown out)

I have an issue which may or may not be related to rough idle. When I fill it up with gas (anything over 5 gallons) it is hard to start and does not hold idle at all for about a minute, however if I keep RPM above 1000 using the gas pedal, then it runs just fine after only difficulty starting. After a minute or so is passed, I can let go of the throttle and it returns to it's normal rough idle

Rough idle seems to be worse when cold, but is sometimes as bas as ever while hot after 1 hour of highway driving.

If I give it some gas, RPM is very steady and normal

When I got the car, there was a code for bad turbo solenoid A, I don't remember the exact code,
The turbo boost pressure control solenoid valve was replaced and that code went away

On very rare occasion, the car will go into limp home mode. Restarting the car fixes this.

Fuel consumption same as my other XC70 at around 12.2L per 100 km during winter, 10.4L per 100 km during summer

There is one code that is always present and I don't know what it is
EVAP canister shut-off valve ECM-4019

The rough idle problem appears to be slowly getting worse.

About every other day, the engine will just die when arriving at a stop sign or after stopping to park. Once it even died while coasting after exiting the highway

Some days are worse than others, sometimes it's totally fine, idle's fine and it doesn't die.
Colder appears to be worse, but I've had bad warm days and good cold days

Every time I hook up VIDA I take screenshots of the fault codes

You can view these screenshots here



I have a few theories
bad throttle position sensor in the ETM ? (seems to be a popular issue, however I have no ETM fault code and throttle is very responsive when not just idling?)

vacuum leak, possibly related to the evap canister shut off valve ?

Maybe broken evap line is causing bad idling by letting boost air out and messing up the fuel mix ?

Intake leakage maybe from turbo piping or at the intercooler ?

I'm not sure where to start, right now it's still too cold outside to be working on this more than a few minutes at a time.

But I can hook up VIDA and run test and record data in the warm interior

Are there things I can check from VIDA to confirm the throttle is working correctly ?

I recorded a video of the rough idle, audio recording is not as good as I'd hoped, sometime you can barely hear anything despite the actually loud exhaust

It is still currently uploading but should be completed in 2 hours


I think I may have occasional misfires, perhaps I have a bad coil, but I don't have bad coil errors. It could also just be the engine being rough at low RPM I'm not sure I can tell the difference

User avatar
darrylrobert
Posts: 177
Joined: Fri Mar 06, 2020 6:25 am
Year and Model: 2001 v70xc
Location: australia
Has thanked: 3 times
Been thanked: 7 times
Australia
darrylrobert

Re: XC70 2001 with rough idle but otherwise works great

Post by darrylrobert » Mon Mar 16, 2020 3:10 am

theresa solenoid valve located on the fan shroud that can cause some of the symtoms you have like hard starting after filling fuel.

User avatar
oragex
Posts: 4808
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 95 times
Been thanked: 265 times
Contact:
Canada
oragex

Re: XC70 2001 with rough idle but otherwise works great

Post by oragex » Mon Mar 16, 2020 5:22 am

Didn't read all, but maybe the fuel pump is about to fail ? Also thinking about the ETM on these early XC70 As for the evap code, maybe check this valve - I believe on 2001 it's located on the radiator fan www.youtube.com/watch?v=0H2lIuQ8e34
Last edited by oragex on Mon Mar 16, 2020 9:36 am, edited 1 time in total.
These users thanked the author oragex for the post:
PixelDust

User avatar
abscate
MVS Moderator
Posts: 21028
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 315 times
Been thanked: 971 times
Trinidad & Tobago
abscate

Re: XC70 2001 with rough idle but otherwise works great

Post by abscate » Mon Mar 16, 2020 8:07 am

The evap shut off valve is down near the evap canister, rear wheel, passenger side (NA market)

Bit of a struggle to reach
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
vtl
Posts: 1839
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 59 times
United States of America
vtl

Re: XC70 2001 with rough idle but otherwise works great

Post by vtl » Mon Mar 16, 2020 9:44 pm

Hole in air intake, ECM-262A says that. ECM-4019 says what can substitute a hole.

Crimp the hose coming from EVAP system, see how it idles. If it's still uneven, smoke-test the intake.
05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

User avatar
darrylrobert
Posts: 177
Joined: Fri Mar 06, 2020 6:25 am
Year and Model: 2001 v70xc
Location: australia
Has thanked: 3 times
Been thanked: 7 times
Australia
darrylrobert

Re: XC70 2001 with rough idle but otherwise works great

Post by darrylrobert » Thu Mar 19, 2020 11:48 pm

what cvvt valve have you got?..ive its the old type like i had it can click like its working (no codes) but when i removed it i realised the mechanical pushrod part was seized. the cvvt valve causes rough idle, poor fuel economy hard starts when hot

shodanx
Posts: 14
Joined: Mon Dec 10, 2018 8:04 pm
Year and Model: xc70 2001
Location: New York
Has thanked: 0
Been thanked: 0
Canada
shodanx

Re: XC70 2001 with rough idle but otherwise works great

Post by shodanx » Sat May 23, 2020 2:21 am

Hi,

Quick follow up, my friend has the car for the past few months.
The AC compressor is dying, exacerbating the bad idle issue, makes a huge racket every time he starts it.

In the parking lot we tried disable the ac compressor by removing fuse no8, but unfortunately this also disabled the drive-by-wire throttle, poor design !!

So tomorrow he is coming over, we are going to get the car on jacks and have a look at trying to disconnect the AC compressor clutch.
Maybe we can disconnect at the AC clutch or maybe we can remove the AC clutch relay, not sure yet.

When we removed the fuse no8, the car would start much easier and without making horrible noises, however the unstable idle was still there.

As per the above comments, we tried to clamp the evap hose, however I'm not sure I got the right hose -OR- it doesn't do anything.

Looking at some youtube videos, I get the impression something about the EVAP line actually goes in the driver seat wheel well, behind those riveted mud flaps ? I hope not, I don't have the right rivets to go digging under there.

I haven't bought a smoke test machine, I really should have, maybe I can jerry rig a way to make a smoke test...

All this is making the car really suck to drive, it shuts off randomly when you're at a stop sign, really hope I can make it suck less tomorrow... Other than this very nagging issue, the car runs fine, the suspension is all good and when at speed the engine runs great, 4x4 works abs works everything else works

User avatar
darrylrobert
Posts: 177
Joined: Fri Mar 06, 2020 6:25 am
Year and Model: 2001 v70xc
Location: australia
Has thanked: 3 times
Been thanked: 7 times
Australia
darrylrobert

Re: XC70 2001 with rough idle but otherwise works great

Post by darrylrobert » Sat May 23, 2020 4:52 am

wow, maybe after 600k kms the car is very tired?..i think like my 2001 car it has multiple issues that will take time and patience. My car had a rough idle caused by a few things but i think the vvt solenoid being stuck improved it alot. I also had a dropout in rpm and it was the gas pedal. Each thing you fix the car will get alittle better.

evap valve shutoff is what i would be looking for, if you find it, the canister is above the rear axle, visible under the car or apparently if you remove the left rear you can remove it. I still havent located the valve on my car, when i test it on VIDA i hear nothing.

Removing the AC relay will stop it from engaging.

User avatar
darrylrobert
Posts: 177
Joined: Fri Mar 06, 2020 6:25 am
Year and Model: 2001 v70xc
Location: australia
Has thanked: 3 times
Been thanked: 7 times
Australia
darrylrobert

Re: XC70 2001 with rough idle but otherwise works great

Post by darrylrobert » Sat May 23, 2020 5:13 am

I found this diagram from another forum, the poster said it was for a xc90 but didnt say what year.

I cannot find item 4 which is the canister shut off valve on my 2001xc70, if you find it please let me know where. thanks

Oh and apparently there was a recall on these canisters
evap valve.jpg
canister valve

shodanx
Posts: 14
Joined: Mon Dec 10, 2018 8:04 pm
Year and Model: xc70 2001
Location: New York
Has thanked: 0
Been thanked: 0
Canada
shodanx

Re: XC70 2001 with rough idle but otherwise works great

Post by shodanx » Sat May 23, 2020 1:24 pm

How can I tell if the VVT solenoid is in cause ? I'm worried of remove it but the connector or the part breaking during removal. I have dice, is there any way to check there ? Maybe, relative cam angle measurement somewhere ?

Thanks darrylrobert, I see the soleinoid valve you mentioned on march 16, I will look closely for it.

The car is about to come here, I will take lots of pictures.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post