IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

850 amp keeps blowing fuse #7

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Richard99
Posts: 49
Joined: Tue May 22, 2018 2:45 pm
Year and Model: 2000 V70XC
Location: San Francisco
Has thanked: 11 times
Been thanked: 1 time
United States of America
Richard99

850 amp keeps blowing fuse #7

Post by Richard99 » Sat Mar 21, 2020 7:47 pm

Hello,

I recently installed a Volvo 850, 4x50w amp + SC-901 radio in my 2000 V70XC. I had used the amp for about 2 months before one day I noticed the radio didn't work.

To diagnose, I checked the fuses to find #7 ((fuse for radio/amp (20 amp)) was blown. When I tried to replace it, the fuse immediately blew. Next, I removed the amp and wiring harness and plugged in the radio with the stock connections, added a fuse and it didn't blow. After that, I checked the amp wiring harness for both continuity with a DMM and visually for split/cracked wires and found none. This leads me to believe that the amp is the problem and am curious if I can repair it.

I've attached a picture of the circuit board for the amp but couldn't find anything obvious. Any ideas?

Thanks,

Eric
Attachments
IMG-2065.jpg
Eric

1998 Volvo V70
2000 Volvo V70XC

scot850
Posts: 5764
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 187 times
Canada
scot850

Re: 850 amp keeps blowing fuse #7

Post by scot850 » Sat Mar 21, 2020 8:01 pm

May be worth buzzing out the cable to make sure there are no shorts. The amp will draw a lot more power than the radio, especially as the SC901 has no built in amplifier, so maybe the amp is only the final straw to another wiring issue elsewhere?? Also, although the radio is coming on, it does not mean it is not the issue either.

I would offer to send another amp and cable to you to try, but they are not accessible in the storage unit for some time to come.

Do you still have the original radio? If not you can usually get one pretty cheap at a junkyard. Get a SC-815 or 6 and try and see if that works ok as the amp is built in in those (actually the amp is built in in most of the older P80/940/960 radios).

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

Richard99
Posts: 49
Joined: Tue May 22, 2018 2:45 pm
Year and Model: 2000 V70XC
Location: San Francisco
Has thanked: 11 times
Been thanked: 1 time
United States of America
Richard99

Re: 850 amp keeps blowing fuse #7

Post by Richard99 » Sat Mar 21, 2020 8:15 pm

Hi Neil,

Thanks for the suggestions. I did do a continuity test with every wire of the amp harness and each one passed the test. I also found no cracks of any kind on any wires of the harness.

I think I forgot to mention that I unplugged the radio completely and it blew a fuse with the radio completely not in use with only the amp plugged in.
Eric

1998 Volvo V70
2000 Volvo V70XC

scot850
Posts: 5764
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 187 times
Canada
scot850

Re: 850 amp keeps blowing fuse #7

Post by scot850 » Sun Mar 22, 2020 11:24 am

So it still comes back to the same 2 issues. 1) The amp is bad and has a failed component and an internal short, or 2) The extra load the amp pulls over the SC-901 (which as no internal amp so it pulls a low current) is causing a short to manifest somewhere else in the harness.

I have little to no knowledge on what to look for in the amp, so I return to my suggestion of seeing if you can find a more basic radio which has the built in amp and see if it fails again. I pick up basic versions of the radio at junkyards for about $15 CDN. I appreciate that in CA it may be difficult to get out these days to get one though. I know my brother lives in Santa Rosa, and the Pick n Pulls around there used to have several older Volvos in there as he pulls parts for his 97 850.

Neil.
These users thanked the author scot850 for the post:
Richard99
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

User avatar
erikv11
Posts: 9587
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 90 times
Been thanked: 261 times
United States of America
erikv11

Re: 850 amp keeps blowing fuse #7

Post by erikv11 » Sun Mar 22, 2020 11:54 am

Mine does the same thing, I am running with no amp now, here is a recap of my less thorough experience viewtopic.php?t=91281.

Given that this failure is semi-common, my guess (!) is the amp. But good suggestions from Neil to just to rule out the harness - test with another unit or just hook up a load to the amp power supply.

Someone was posting up to offer repair of the amps, I will see if I can find the post ... here it is viewtopic.php?f=6&t=91782. Maybe contact him and he can tell you where to look in the amp. Or send it to him.
These users thanked the author erikv11 for the post:
Richard99
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 285k
'06 S60 R, 165k
'99 Camry V6 :shock: 125k
gone: '96 NA 850 210k, '98 NA V70 182k

Richard99
Posts: 49
Joined: Tue May 22, 2018 2:45 pm
Year and Model: 2000 V70XC
Location: San Francisco
Has thanked: 11 times
Been thanked: 1 time
United States of America
Richard99

Re: 850 amp keeps blowing fuse #7

Post by Richard99 » Sun Mar 22, 2020 5:25 pm

Thanks, guys. I will follow your suggestions. Either way, I was planning on installing the 4x100 W amp from a C70.

Eric
Eric

1998 Volvo V70
2000 Volvo V70XC

Post Reply
  • Similar Topics
    Replies
    Views
    Last post