IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

1990 Volvo 240- Bizarre Temp Gauge Isssues

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Post Reply
rice240
Posts: 9
Joined: Thu Mar 27, 2014 11:17 am
Year and Model: 90 240 and 94 850T
Location: Houston, Texas

1990 Volvo 240- Bizarre Temp Gauge Isssues

Post by rice240 »

My temp gauge read really low for a while and then it read high, just below the red. Sometimes it would just drop suddenly. So I bypassed the temp compensating board. No change. I bought a new sensor, no change. I grounded the lead and it went high but not all of the way. IF I unplug it it goes down to cool but not to the bottom. I then grounded it to the negative battery terminal with a test light and the light came on very faint. I guess it is getting a signal from some electrical problem.

BTW I installed a TEMP gauge in the hose AFTER the thermostat so I can see that it is opening. car runs on that on at about 175.F. Where could it be picking up a signal when it's unplugged?

I give up! Help!
User avatar
RickHaleParker
Posts: 4694
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 603 times

Re: 1990 Volvo 240- Bizarre Temp Gauge Isssues

Post by RickHaleParker »

IMG_0001.jpg
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD.
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
User avatar
93Regina
Posts: 2813
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Been thanked: 64 times

Re: 1990 Volvo 240- Bizarre Temp Gauge Isssues

Post by 93Regina »

>My temp gauge read really low for a while and then it read high

Yeah, I bought a 1989 Volvo, which had the high read issue...previous owner who bought it a month earlier 'freak' on it, and sold it to me. He had replaced water pump and thermostat...he never told me about it.

I had a electronic tech inspect instrument panel, and he replaced some electrical parts, which mostly made this issue disappear. I installed a cooler thermostat, which was used in earlier years, but I do longer daily runs. It's not red-lining now.

I'm not concerned about it, but if a new wire was installed, from temp sensor to panel's plug, I suspect this issue might disappear.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post