IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Intermittent loss of power

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

protonsnow
Posts: 5
Joined: Fri Mar 27, 2020 9:56 am
Year and Model: 2000 Volvo v70 mk2T5
Location: Lisbon
Has thanked: 0
Been thanked: 0
Portugal
protonsnow

Intermittent loss of power

Post by protonsnow » Fri Mar 27, 2020 10:09 am

Hi Everyone,

I own a 2000 Volvo v70 T5 (mk2) manual gears with 355,000 km. It has a strange problem that does not throw any codes. If I drive slowly for while (below 2000 rpms), of if I get stuck in traffic, then when I want to accelerate it seems the turbo won't engage and the car makes more noise with only about 30% of the power it should have. It really struggles to get up hills, especially in 3rd gear. If I always drive fast (which is my normal MO) everything is always fine and as powerful as it should be.
As I said, I have no codes on the computer and I have recently changed the following parts, some to try and fix the problem, most simply because they needed changing:
- spark plugs (original volvo)
- MAF sensor (Basch)
- timing belt and water pump
- oil and oil filter
- air filter
- engine mounts
- brake disks and pads
- radiator
- front sway bar
- tires
- oil trap
- engine breather hoses (PCV)
- battery
- some vaccum hoses

At first I was thinking some bad contact somewhere could be the culprit, before I had established a pattern, but the problem always occurs after driving slow for about 5 minutes.
Any ideas what could be causing this?

Thanks

User avatar
RickHaleParker
Posts: 4203
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 538 times
United States of America
RickHaleParker

Re: Intermittent loss of power

Post by RickHaleParker » Fri Mar 27, 2020 3:06 pm

protonsnow wrote:
Fri Mar 27, 2020 10:09 am
As I said, I have no codes on the computer
What are you using to read codes?
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

protonsnow
Posts: 5
Joined: Fri Mar 27, 2020 9:56 am
Year and Model: 2000 Volvo v70 mk2T5
Location: Lisbon
Has thanked: 0
Been thanked: 0
Portugal
protonsnow

Re: Intermittent loss of power

Post by protonsnow » Fri Mar 27, 2020 3:21 pm

DiCE and VIDA 2014

User avatar
RickHaleParker
Posts: 4203
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 538 times
United States of America
RickHaleParker

Re: Intermittent loss of power

Post by RickHaleParker » Fri Mar 27, 2020 3:31 pm

Did you clean the ETM when you did the PCV and Oil trap?
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

protonsnow
Posts: 5
Joined: Fri Mar 27, 2020 9:56 am
Year and Model: 2000 Volvo v70 mk2T5
Location: Lisbon
Has thanked: 0
Been thanked: 0
Portugal
protonsnow

Re: Intermittent loss of power

Post by protonsnow » Fri Mar 27, 2020 3:58 pm

sprayed it a bit with carb cleaner, but did not take apart...

User avatar
RickHaleParker
Posts: 4203
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 538 times
United States of America
RickHaleParker

Re: Intermittent loss of power

Post by RickHaleParker » Fri Mar 27, 2020 4:04 pm

protonsnow wrote:
Fri Mar 27, 2020 3:58 pm
sprayed it a bit with carb cleaner, but did not take apart...
You do not need to take it apart. Just get the bore where the butterfly is located clean, all the way through.

Did you get it the bore and butterfly clean?
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

protonsnow
Posts: 5
Joined: Fri Mar 27, 2020 9:56 am
Year and Model: 2000 Volvo v70 mk2T5
Location: Lisbon
Has thanked: 0
Been thanked: 0
Portugal
protonsnow

Re: Intermittent loss of power

Post by protonsnow » Fri Mar 27, 2020 4:08 pm

I would say clean(ish) - but way better than it was before I sprayed it half a dozen times. In retrospect, I could have spent a little more time on it, but before and after symptoms are exactly the same, so either my spraying didn't do anything, or the problem should have changed (improved) a bit.

User avatar
ndphotonl
Posts: 201
Joined: Sun May 27, 2018 7:09 am
Year and Model: 2001 S80 2.4T
Location: Netherlands
Has thanked: 26 times
Been thanked: 25 times
Contact:
Netherlands
ndphotonl

Re: Intermittent loss of power

Post by ndphotonl » Fri Mar 27, 2020 4:47 pm

If the TCV has never been changed, change it. I can highly recommend this Pierburg unit, which is used in several Porsches and is also known as the HD unit.

Also check the workings of the wastegate actuator.

ImageVolvo S80 2.4T Pierburg TCV 7.22908.03.0 by Andy Ramdin, on Flickr

ImageVolvo S80 2.4T Pierburg TCV 7.22908.03.0 by Andy Ramdin, on Flickr

ImageVolvo S80 2.4T Pierburg TCV 7.22908.03.0 by Andy Ramdin, on Flickr
Volvo S80 2.4T Wasa Limited Edition
Blog / FlickR / YouTube channel

protonsnow
Posts: 5
Joined: Fri Mar 27, 2020 9:56 am
Year and Model: 2000 Volvo v70 mk2T5
Location: Lisbon
Has thanked: 0
Been thanked: 0
Portugal
protonsnow

Re: Intermittent loss of power

Post by protonsnow » Sat Mar 28, 2020 3:58 am

Thank you.
That's definitely a possibility. I will try to test the TCV later to see if I can pinpoint the issue (according to these tests: viewtopic.php?t=63924).
I have also set up and ELM127 OBD2 reader with Torque Pro on my android so I can monitor the turbo pressure while driving (car does not have a turbo boost gauge).
I'll report back with my findings.

Thank you very much for your time and brain power.

User avatar
ndphotonl
Posts: 201
Joined: Sun May 27, 2018 7:09 am
Year and Model: 2001 S80 2.4T
Location: Netherlands
Has thanked: 26 times
Been thanked: 25 times
Contact:
Netherlands
ndphotonl

Re: Intermittent loss of power

Post by ndphotonl » Sat Mar 28, 2020 5:12 pm

There is a simple test you can perform with the TCV. Blow through the tubes, a brand new TCV flows with very little/without obstruction. If you need to blow quite hard, then consider replacing it.

Only 2 holes are open if my memory serves me correct, the other one is closed by default.
These users thanked the author ndphotonl for the post:
sebrenite
Volvo S80 2.4T Wasa Limited Edition
Blog / FlickR / YouTube channel

Post Reply
  • Similar Topics
    Replies
    Views
    Last post