IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Wiper issue - no park, no intermittent sitting

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
smacknab
Posts: 277
Joined: Wed Sep 25, 2019 4:23 pm
Year and Model: 99 s70 NA Manual
Location: Boston
Has thanked: 58 times
Been thanked: 12 times
United States of America
smacknab

Wiper issue - no park, no intermittent sitting

Post by smacknab » Thu Apr 02, 2020 3:51 pm

Hi everyone I've tried swapping the relay, the stalk and now the motor and I still have this issue. The top wiper setting doesn't work and the wipers don't park when I turn them off. The connections on the stalk side and the motor seem fine to me.

Does this only leave the wiring to and from the relay board as the potential issue? It seems really inaccessable so im not sure where to go from here.

This is on my 99 s70
99 s70 NA m56 - >213k miles

User avatar
RickHaleParker
Posts: 4206
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 539 times
United States of America
RickHaleParker

Re: Wiper issue - no park, no intermittent sitting

Post by RickHaleParker » Thu Apr 02, 2020 7:20 pm

Do the stop at the same spot every time or wherever they happens to be when you turn the switch off?
These users thanked the author RickHaleParker for the post:
smacknab
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

User avatar
smacknab
Posts: 277
Joined: Wed Sep 25, 2019 4:23 pm
Year and Model: 99 s70 NA Manual
Location: Boston
Has thanked: 58 times
Been thanked: 12 times
United States of America
smacknab

Re: Wiper issue - no park, no intermittent sitting

Post by smacknab » Thu Apr 02, 2020 9:02 pm

Hi Rick, they stop wherever they happen to be. I park them manually by dipping the stalk till it's back in place.
99 s70 NA m56 - >213k miles

User avatar
RickHaleParker
Posts: 4206
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 539 times
United States of America
RickHaleParker

Re: Wiper issue - no park, no intermittent sitting

Post by RickHaleParker » Thu Apr 02, 2020 10:07 pm

There is a cam driven switch on the wiper motor that keeps the motor alive until it reaches the park position. If the contacts on the switch are burnt or worn open the motor will not stay alive when you shut off the power with the wiper switch.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

User avatar
abscate
MVS Moderator
Posts: 21028
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 315 times
Been thanked: 971 times
Trinidad & Tobago
abscate

Re: Wiper issue - no park, no intermittent sitting

Post by abscate » Fri Apr 03, 2020 4:38 am

That sounds like a problem internal to the wiper motor as a Rick points out. Time to hit the PnP
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
smacknab
Posts: 277
Joined: Wed Sep 25, 2019 4:23 pm
Year and Model: 99 s70 NA Manual
Location: Boston
Has thanked: 58 times
Been thanked: 12 times
United States of America
smacknab

Re: Wiper issue - no park, no intermittent sitting

Post by smacknab » Fri Apr 03, 2020 6:44 am

Interesting.. I did just try swapping in a tested used motor and plugged it in without the blades on, but it had the same problem. No function on the intermittent setting and when I turned the switch off the motor would immediately shut off. So either I got a motor with the exact same problem, or I have a different issue.
99 s70 NA m56 - >213k miles

User avatar
abscate
MVS Moderator
Posts: 21028
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 315 times
Been thanked: 971 times
Trinidad & Tobago
abscate

Re: Wiper issue - no park, no intermittent sitting

Post by abscate » Fri Apr 03, 2020 7:04 am

You can see the switch pin assignments and connects on the Alldata diagram below.

Looks like fun, but trouble shoot the switch by pulling the connector and testing for continuity as shown in the little insert

If there are no intermittants and the switch is good, the 2/4 relay (labelled 203) might be bad.
Attachments
Screen Shot 2020-04-03 at 9.00.09 AM.png
Screen Shot 2020-04-03 at 9.00.09 AM.png (232.18 KiB) Viewed 66 times
Screen Shot 2020-04-03 at 8.59.48 AM.png
Screen Shot 2020-04-03 at 8.59.48 AM.png (214.48 KiB) Viewed 66 times
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
abscate
MVS Moderator
Posts: 21028
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 315 times
Been thanked: 971 times
Trinidad & Tobago
abscate

Re: Wiper issue - no park, no intermittent sitting

Post by abscate » Fri Apr 03, 2020 7:07 am

Here is the switch guidance - the diagram is a bit sucky because you have to use the grey box to get the right assignments for pins 1-8, then use the map to see which assignment connects to which.

Someone wasnt being very friendly when they wrote that
Attachments
Screen Shot 2020-04-03 at 9.08.19 AM.png
Screen Shot 2020-04-03 at 9.08.19 AM.png (36.79 KiB) Viewed 62 times
Screen Shot 2020-04-03 at 9.05.28 AM.png
Screen Shot 2020-04-03 at 9.05.28 AM.png (11.77 KiB) Viewed 63 times
Screen Shot 2020-04-03 at 9.05.11 AM.png
Screen Shot 2020-04-03 at 9.05.11 AM.png (14.5 KiB) Viewed 63 times
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
RickHaleParker
Posts: 4206
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 539 times
United States of America
RickHaleParker

Re: Wiper issue - no park, no intermittent sitting

Post by RickHaleParker » Fri Apr 03, 2020 12:52 pm

smacknab wrote:
Fri Apr 03, 2020 6:44 am
Interesting.. I did just try swapping in a tested used motor and plugged it in without the blades on, but it had the same problem. No function on the intermittent setting and when I turned the switch off the motor would immediately shut off. So either I got a motor with the exact same problem, or I have a different issue.
Are positions 1 - 4 working as they should be or is there a defect other then not parking?
Another defect would be useful in diagnosing this.
IMG_0001.jpg
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

User avatar
smacknab
Posts: 277
Joined: Wed Sep 25, 2019 4:23 pm
Year and Model: 99 s70 NA Manual
Location: Boston
Has thanked: 58 times
Been thanked: 12 times
United States of America
smacknab

Re: Wiper issue - no park, no intermittent sitting

Post by smacknab » Fri Apr 03, 2020 2:15 pm

RickHaleParker wrote:
Fri Apr 03, 2020 12:52 pm

Are positions 1 - 4 working as they should be or is there a defect other then not parking?
Another defect would be useful in diagnosing this.
Based on the diagram, the position 3 isn't working. Also I had tried swapping the relay first with the 99 relay from a vw but I had the same problem regardless. I'll have to look into the wiring diagrams soon and pull out the multimeter!

I should add, the car doesnt have the headlight wipers so i actually have no clue if those work either!
99 s70 NA m56 - >213k miles

Post Reply
  • Similar Topics
    Replies
    Views
    Last post