IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

OBD (Part A) replaement 95 S/W None Turbo Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

theiceman69
Posts: 5
Joined: Wed Aug 16, 2017 6:00 am
Year and Model: 850 - 1995
Location: Botswana
Has thanked: 0
Been thanked: 0
Botswana
theiceman69

OBD (Part A) replaement 95 S/W None Turbo

Post by theiceman69 » Tue Apr 07, 2020 12:37 am

I finally had to change the OBD - Part A- it surrendered to 25 years of heat, engine and ambient(40c+)
Managed to get the old one to pieces, replaced with new parts. Switched on the ignition, (No 7 selected) , one bright flash from lamp. When using the button to try to read codes, :oops: nothing!!
What have I missed out OR what did I not do to make the new item(s) work

User avatar
gmh
Posts: 158
Joined: Sat May 30, 2009 7:39 pm
Year and Model: 97 850 R Wagon
Location: Lafayette, CO
Has thanked: 13 times
Been thanked: 15 times
United States of America
gmh

Re: OBD (Part A) replaement 95 S/W None Turbo

Post by gmh » Tue Apr 07, 2020 1:10 pm

I assume you have seen this:
https://www.matthewsvolvosite.com/read-codes-volvo-850
Do any of the other ports (A or B) work?
Can you read engine codes from A2?
Gary

1969 145S (1987-91)
1973 145E (1989-90)
1981 245 (1990-2001)
1981 244 (1991-2002)
1989 760 Turbo Wagon (1999-2011)
1994 850 Turbo Wagon (2002-2013) burnt valve
2001 V70 2.4T (2009-2017) sold
1997 850 R Wagon (2013-present)
2014 XC60 T6 (2017-present)

theiceman69
Posts: 5
Joined: Wed Aug 16, 2017 6:00 am
Year and Model: 850 - 1995
Location: Botswana
Has thanked: 0
Been thanked: 0
Botswana
theiceman69

Re: OBD (Part A) replaement 95 S/W None Turbo  Topic is solved

Post by theiceman69 » Wed Apr 08, 2020 6:33 am

Gary, thanks for the response. Yes I have (printed most of it).
Not initially ( removed - batt terminal for about 10 mins), replaced it, now the OBD seems to be responding - in the main. On one or two positions I have no or strange results i.e. selecting Pos A7when the button is pressed, the lamp flickers (tried two or three times, then it came back , 1 1 1 ).
Still remain with biggest problem, the ABS. Warning lamp has been on for months - so many different reasons given for it's being there (including 2 from the local[and only] Volvo dealership ),their advice "replace the ABS unit". Quite costly here! If I had not the results from the OBD when used in the past, these vary from 'front left wheel - sensor to 411/413 and 415. I'm not clever enough to know how to fix these thing, if indeed they are even fixable but untiIl have a definite cause or reason, the lamp can stay on, no real detriment to the braking system.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post