IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

no boost in 05 xc70

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Clockboy
Posts: 105
Joined: Tue Jan 13, 2015 9:24 pm
Year and Model: 05 xc70, v70 2.5t 06
Location: New york
Has thanked: 2 times
Been thanked: 1 time
United States of America
Clockboy

no boost in 05 xc70

Post by Clockboy » Fri Apr 10, 2020 10:27 am

I just did the timing belt and pcv system on my wife's 05 xc70. In doing so I cleaned the throttle body and replaced the gasket. The car started, but it had a rolling idle almost stalling out. It threw a throttle code. I started it again and it was idling fine, but now is not boosting. Just sounds like a bad exhaust system with no power when accelerating and expecting the boost.. Normal driving sounds fine. Is it possible the throttle body still needs to be adapted to the system and that is why there is no turbo boost or is it more likely a vacuum leak or exhaust constriction? Still have to look at everything closer, but wanted to perhaps eliminate the throttle body.

User avatar
SuperHerman
Posts: 1465
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 157 times
United States of America
SuperHerman

Re: no boost in 05 xc70

Post by SuperHerman » Sat Apr 11, 2020 2:10 pm

First thing you need to do is check all your hoses. Good chance one was dislodged and/or incorrectly placed in the wrong spot. Always check your work if you have a problem as well as any thing nearby.

Next check your vacuum hoses - starting at the turbo and going to the boost control solenoid where it should then branch off with two more hoses if I recall. Many times the hose at the turbo has disintegrated and is the cause of the problem.

User avatar
darrylrobert
Posts: 180
Joined: Fri Mar 06, 2020 6:25 am
Year and Model: 2001 v70xc
Location: australia
Has thanked: 3 times
Been thanked: 7 times
Australia
darrylrobert

Re: no boost in 05 xc70

Post by darrylrobert » Sun Apr 12, 2020 2:42 am

From personal experience i avoid doing multiple repairs at the same time. You need to backtrack and check all your work.

User avatar
shiloh51933
Posts: 940
Joined: Fri Mar 05, 2010 7:12 pm
Year and Model: 04 XC70/'98 V70XC
Location: New York
Has thanked: 11 times
Been thanked: 10 times
United States of America
shiloh51933

Re: no boost in 05 xc70

Post by shiloh51933 » Sun Apr 12, 2020 9:45 am

Even when you disconnect the battery the learning curve for the ECM/Network is extremely quick...regardless she should still have boost. If you have a DTC for the ETM the you need to retrace your steps in that area. Is there any messages on the cluster screen?
If U Wanna Play U Gotta Pay!!

User avatar
abscate
MVS Moderator
Posts: 21081
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 317 times
Been thanked: 982 times
Trinidad & Tobago
abscate

Re: no boost in 05 xc70

Post by abscate » Sun Apr 12, 2020 7:41 pm

The throttle body’s on P2s is pretty reliable. Almost any code from engine management side will inhibit boost. Its a vacuum line or electrical disconnect somewhere.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Clockboy
Posts: 105
Joined: Tue Jan 13, 2015 9:24 pm
Year and Model: 05 xc70, v70 2.5t 06
Location: New york
Has thanked: 2 times
Been thanked: 1 time
United States of America
Clockboy

Re: no boost in 05 xc70

Post by Clockboy » Fri Apr 24, 2020 2:13 pm

I went back and took a look at everything. When I looked at the intake pipe for the throttle body it was sort of on. Gave it a little tap and it fell off. Then I remembered putting the parts back together sort of out of sequence and having to reach and curse my way to getting it on. Obviously I did not say the right curses because it was not on. It is now and there is plenty of boost. Induction, induction, induction. Thanks to all.

User avatar
- Pete -
Posts: 627
Joined: Fri Dec 06, 2013 10:13 pm
Year and Model: 01, 04, 04, 04 V70's
Location: Minnesota/Wisconsin
Has thanked: 55 times
Been thanked: 77 times
United States of America
- Pete -

Re: no boost in 05 xc70

Post by - Pete - » Fri Apr 24, 2020 2:44 pm

The curse words need to be uttered in the correct dialect of Swedish, as per ViDA.
2001 V70XC 146k
2004 V70 AWD 141k
2004 V70R M66 144k
2004 XC70 287k
2006 XC70 155k Sold

User avatar
abscate
MVS Moderator
Posts: 21081
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 317 times
Been thanked: 982 times
Trinidad & Tobago
abscate

Re: no boost in 05 xc70

Post by abscate » Sat Apr 25, 2020 5:02 am

- Pete - wrote:
Fri Apr 24, 2020 2:44 pm
The curse words need to be uttered in the correct dialect of Swedish, as per ViDA.
Link to common Swedish swear words



https://hejsweden.com/en/swedish-swear-words/

Javla Tyskar!
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Post Reply
  • Similar Topics
    Replies
    Views
    Last post