IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

2004 S80 2.9 non-turbo: Starting issues

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
Post Reply
dejongmc
Posts: 184
Joined: Tue Dec 19, 2006 11:56 am
Year and Model: 2004 Volvo S80
Location: Houston

2004 S80 2.9 non-turbo: Starting issues

Post by dejongmc »

Hello,

Recently I had to move my car about 6ft to make space for one of our other cars and ever since I'm not able to start it anymore.
So far I did the following trouble shooting:
- The starter does work, but the engine doesn't crank
- Checked the battery if it holds a charge > ok
- Before I took the battery out to test it, I was able to read the following codes: P0420, P0430, P0455. But even with these codes I think the car should still be able to start.

For a while I know that my ABS module needs to be replaced, but I do not think it has anything to do with this issue.
Next thing I want to check is the fuel system, but I'm not sure how to trouble shoot that.

So I'm asking for any other trouble shooting steps to narrow down this issue.

Thanks,
1997 850 NA Wagon - 261,000 miles - Is no longer
2004 V70 NA Wagon - Saved my life
2004 S80
User avatar
ndphotonl
Posts: 212
Joined: Sun May 27, 2018 7:09 am
Year and Model: 2001 S80 2.4T
Location: Netherlands
Has thanked: 26 times
Been thanked: 28 times
Contact:

Re: 2004 S80 2.9 non-turbo: Starting issues

Post by ndphotonl »

Crankshaft position sensor most likely. Did it also shut down without any warning? If yes, than most likely that sensor.
Volvo S80 2.4T Wasa Limited Edition
Blog / FlickR / YouTube channel
User avatar
bmdubya1198
Posts: 4337
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 45 times
Been thanked: 182 times

Re: 2004 S80 2.9 non-turbo: Starting issues

Post by bmdubya1198 »

How long did it run when you moved it, and did this start just after moving it? This sounds like classic symptoms of lawnmower syndrome. See here... viewtopic.php?t=18175

Those codes won't prevent the car from running, they're for cat efficiency and an evap leak. When you said the starter works, you mean that the engine is actually cranking over, just not starting, correct?
'00 V70R Venetian Red/Charcoal M56 Swapped 199k
'03 S60 2.4T Silver/Black 117k
'07 XC90 V8 AWD Sport Titanium Grey/Black 174k
'91 944 Turbo Dark Green/Beige 175k
'92 245 Base White/Beige 249k
'99 BMW 528i
'01 Mountaineer 5.0
Sold-
2000 S70 GLT Mystic Silver/Taupe 253k
1993 944 Base Beige/Beige 221k
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k
Post Reply
  • Similar Topics
    Replies
    Views
    Last post