Amazon Cyber Monday 2020
IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Volvo 850 T-5 K24 won't run. Looking for ideas! Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
User avatar
Sanatarium
Posts: 21
Joined: Sun Apr 19, 2015 10:34 pm
Year and Model: 2010 C30, 97 850 T-5
Location: Phoenix
Has thanked: 3 times
Been thanked: 2 times

Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sanatarium »

Hi gang. I don't post as much as I should, but having a baby leaves me with little time, I barely get to work on my car, let alone document and write about it. I have been working on a K24 upgrade for my 850, it's a 97 wagon, with mint leather and KW coils, my garage queen at the moment :) I have lots of photos from this K24 build I have been working on for several months though that I hope to share. Anyway, I am stuck right now!
Car:
1997 850 T-5 Wagon

Problem:
The car will start but runs extremely rough and eventually dies within a minute. It puffs and sputters and I would swear there is a hole in the side of the block(there isnt). Lots of smoke and tons of fuel smell, wideband reads in the 8's. There is a tiny amount of grey smoke coming from somewhere in the engine bay near the exhaust manifold, not from the exhaust(there is grey smoke there too)

What I have done since the car last ran
Replaced timing belt and components (timing is good)
K24 and R manifold
Wideband O2(currently not connected to ECU)
Green injectors
DW200 fuel pump
Do88 IC and RIP kit
Vast Tuned ECU

The car also has (and previously ran great with)
Stock ECU
3" downpipe
Pierburg TCV
Stock MAF
Distributor, wires and plugs (10-15k ago)
Original coil
Original cam sensor
Aftermarket fuel pump(30k ago)

What I have checked so far:
Plugs and wires(plugs were wet with fuel but otherwise normal. Small amount of condensed oil in the plug wells, nothing out of the ordinary from my experience)
Coil wire
Cam sensor connector
Swapped in stock ECU

What I plan next:
Check fuel pressure with a gauge
Swap stock injectors back in with stock ecu
Replace coil

Looking for any and all ideas, I have many years experience as a home/diy diesel/gas mechanic, but this one has me stumped! I swear it sounds like an exhaust leak or something, the way it puffs and almost pops, like an old tractor starting...

Thanks,
Last edited by Sanatarium on Sat May 02, 2020 8:29 am, edited 1 time in total.
Sommerfeldt
Posts: 1141
Joined: Tue Jul 29, 2008 1:25 pm
Year and Model: 1996 850 T5
Location: Oslo Area, Norway
Has thanked: 55 times
Been thanked: 37 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sommerfeldt »

Just my 2 öre as it were, but could it be a headgasket issue? Grey smoke sounds a little ominous to me - I guess unburned fuel and water mixed. Could be just condensation, I suppose.

If your plugs are wet, you're not firing on all sylinders, so that's either a spark issue or the stuff that's in there doesn't want to burn, which brings it back around to the HG. How's the oil looking?

- S
'96 855 T5, R bumper and spoiler, Koni Yellows & blue H&R springs all 'round.
User avatar
Sanatarium
Posts: 21
Joined: Sun Apr 19, 2015 10:34 pm
Year and Model: 2010 C30, 97 850 T-5
Location: Phoenix
Has thanked: 3 times
Been thanked: 2 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sanatarium »

Oil looks good, it's fresh, just drained a few oz and its still clean, not milky or frothy. I considered a HG issue but it ran flawlessly prior. Currently only at 132k.
JimBee
Posts: 1775
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model: 93 and 2 96 850's
Location: Minneapolis
Has thanked: 13 times
Been thanked: 28 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by JimBee »

"Stock MAF" but is it known to be good? I had an 850 that behaved like that, the MAF was bad. Try disconnecting it just to confirm. If there's no difference then I wouldn't suspect the MAF.
Sommerfeldt
Posts: 1141
Joined: Tue Jul 29, 2008 1:25 pm
Year and Model: 1996 850 T5
Location: Oslo Area, Norway
Has thanked: 55 times
Been thanked: 37 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!  Topic is solved

Post by Sommerfeldt »

Yeah, what JimBee said. Check that - if it's making you run super rich, then that would account for the symptoms. It'd be good to check that the O2 sensor(s) are working correctly as well, on the heels of that. When my 850 had a milder version of those symptoms, it was the O2, not the MAF. Or a combo.

The "smoke from somewhere in the engine bay" is also worrying. There shouldn't be any back there, especially if it's not from the exhaust. How's your PCV system doing? I'm thinking it might be clogged?

- S
'96 855 T5, R bumper and spoiler, Koni Yellows & blue H&R springs all 'round.
User avatar
Sanatarium
Posts: 21
Joined: Sun Apr 19, 2015 10:34 pm
Year and Model: 2010 C30, 97 850 T-5
Location: Phoenix
Has thanked: 3 times
Been thanked: 2 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sanatarium »

Hey guys thanks for the input. Turns out I installed the P1 exhaust gasket backwards(didn't realize that was possible!) the smoke was exhaust leaking around the gasket.
Anyway, with that corrected the exhaust ports are no longer partially restricted. The car is running 8-10 AFR at 1500 rpm though, but it runs. Has a bit of a sputter that smooths out closer to 2000rpm. I verified the O2 sensor with a torch. 0.9V after some gentle heating for 15 seconds, down to 0.1 after two seconds. I haven't tried unplugging the MAF but will do that next. It was working perfectly prior to this work so I don't suspect it but you never know. PCV system was done 15k ago.
madsking
Posts: 12
Joined: Tue Dec 10, 2019 5:29 am
Year and Model: 96 850 T5
Location: Denmark
Has thanked: 5 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by madsking »

Hi,
I am not an expert but since you replaced injectors with the green ones they might have to run with different fuel pressure than the old injectors. Incorrect FP could cause strange behavior.

Btw where to find those photos of the car build? :D
User avatar
Sanatarium
Posts: 21
Joined: Sun Apr 19, 2015 10:34 pm
Year and Model: 2010 C30, 97 850 T-5
Location: Phoenix
Has thanked: 3 times
Been thanked: 2 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sanatarium »

Well.. Installed the MAF backwards too. Someone save me from myself. I'm going to play the new dad card this time and say I've temporarily lost part of my mind. Car runs sweet now. Will update my car thread soon with build photos.
Here is one with the K24 mounted up in the meantime
Attachments
20200402_211739.jpg
madsking
Posts: 12
Joined: Tue Dec 10, 2019 5:29 am
Year and Model: 96 850 T5
Location: Denmark
Has thanked: 5 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by madsking »

It pays off to be persistent.. Great that you identified the issue! Wonder if it's lack of sleep that has caused it ;)

Anyway nice picture, I would really like to follow that project and good luck with it.
User avatar
Sanatarium
Posts: 21
Joined: Sun Apr 19, 2015 10:34 pm
Year and Model: 2010 C30, 97 850 T-5
Location: Phoenix
Has thanked: 3 times
Been thanked: 2 times

Re: Volvo 850 T-5 K24 won't run. Looking for ideas!

Post by Sanatarium »

Project thread for those interested
viewtopic.php?f=1&t=93840&p=541355#p541355
Post Reply
  • Similar Topics
    Replies
    Views
    Last post