IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Failure to clear code 122 - cruise control

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

theiceman69
Posts: 5
Joined: Wed Aug 16, 2017 6:00 am
Year and Model: 850 - 1995
Location: Botswana
Has thanked: 0
Been thanked: 0
Botswana
theiceman69

Failure to clear code 122 - cruise control

Post by theiceman69 » Sun May 10, 2020 6:22 am

It was working fine before I replaced Part A of the OBD, failed to engage some little while later and now will not reset :!: :roll:

User avatar
rspi
Posts: 7278
Joined: Sat Nov 05, 2011 10:40 am
Year and Model: 850 T-5R Wagon
Location: Albuquerque, NM
Has thanked: 22 times
Been thanked: 49 times
United States of America
rspi

Re: Failure to clear code 122 - cruise control

Post by rspi » Mon May 11, 2020 7:48 am

I believe that's a pre mph requirement code. What's the real issue? Cruise not working?
'95 855 T-5R M, Panther - 22/28 mpg
'98 S70 GLT, Lil' Red 25/32 mpg
--------------------
Volvo's of past: '87 740 GLE, '79 262C Bertone, '78 264, 960's, '98 S70 GLT, '95 850 T-5R YellowVolvo Repair Videos

theiceman69
Posts: 5
Joined: Wed Aug 16, 2017 6:00 am
Year and Model: 850 - 1995
Location: Botswana
Has thanked: 0
Been thanked: 0
Botswana
theiceman69

Re: Failure to clear code 122 - cruise control

Post by theiceman69 » Thu May 14, 2020 5:20 am

rspi wrote:
Mon May 11, 2020 7:48 am
I believe that's a pre mph requirement code. What's the real issue? Cruise not working?
Yes, it fails to engage, I normally select it around 75/78Kph(near to 50Mph) but it does not come in.
It is in the OFF position most of the time - not left ON - as this may pick up a "low speed signal" as it did once before, hence my leaving it OFF.
Tried disconnecting the - side of battery for 10/12 mins but no change. :?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post