IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Engine dead after de grease wash 1990 240

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Mon May 25, 2020 7:19 pm

Hi all

Yes I de greased and sprayed my engine down and killed it !!! Man I’m so lame .
I covered the alternator with a bag, and thought that’s all I would need. I cleaned it and tried starting it , but it died and chugged . I removed distributor and rotor made sure all was dry, pulled the mas air flow sensor and it was drowned . Removed it dried it and the associated piping . I noticed the little sensor inside has two tiny wires attached and I broke one of them. Used a leaf blower and dried all parts, re installed and it runs, but check engine light is on, and it runs like poop! I ordered a new mass airflow sensor. Do I need to replace anything else or do anything else?
My car has been meticulously cared for by pervious owner and myself . Very healthy and taken care of and zero issues before this. Please help I love my car and need to get her “Betty White” back to her old self and never do this again!!!
Thanks I’m advance . Please help
God bless

jamadams11
Posts: 14
Joined: Mon Aug 05, 2019 3:19 pm
Year and Model: 2004 XC90
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
jamadams11

Re: Engine dead after de grease wash 1990 240

Post by jamadams11 » Mon May 25, 2020 7:31 pm

remove cap and check inside for moisture. Clean/replace. Clean/dry plug wires.

Still won't start? Check the Crankshaft speed sensor. the outer casing will crack and allow moisture in.
to check, remove from the car and inspect carefully. or, just replace.

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Re: Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Mon May 25, 2020 7:51 pm

I will install mass air flow sensor tomorrow,
I will also check those things and update you. Thank you so much I really really appreciate your kindness and time and support.

God bless

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Re: Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Mon May 25, 2020 8:20 pm

Could it be anything else if it runs rough?

jamadams11
Posts: 14
Joined: Mon Aug 05, 2019 3:19 pm
Year and Model: 2004 XC90
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
jamadams11

Re: Engine dead after de grease wash 1990 240

Post by jamadams11 » Mon May 25, 2020 8:23 pm

does your car have the fuse holder on the driver's side fender, near to the battery? remove fuse and check socket for corrosion.

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Re: Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Mon May 25, 2020 8:34 pm

Will do I will look if there’s one there. Thanks so much

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Re: Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Tue May 26, 2020 2:06 pm

Replaced mass air flow sensor , starts , drive around block and it feels sluggish, check engine light on. Gonna relplace camshaft sensor

Anything else that I should replace that might account for sluggish and check engine light

User avatar
volvolugnut
Posts: 744
Joined: Sun Jan 19, 2014 9:51 am
Year and Model: 2001 V70
Location: Midsouth USA
Has thanked: 37 times
Been thanked: 79 times
United States of America
volvolugnut

Re: Engine dead after de grease wash 1990 240

Post by volvolugnut » Tue May 26, 2020 7:42 pm

Are you sure you have a camshaft sensor? I can't think of anything on 1990 240 that would use cam position. Crank position sensor for the ignition timing? Perhaps the engine coolant temperature sensor is flaky. It is separate from the dash temperature gauge sensor.

Can you read code from the flashing light system ( I think 1990 had this code system)?

volvolugnut
2001 V70 T5, 1986 244DL, 1983 245DL, 1975 245DL, 1959 PV544, multiple parts cars.

jamadams11
Posts: 14
Joined: Mon Aug 05, 2019 3:19 pm
Year and Model: 2004 XC90
Location: NC
Has thanked: 0
Been thanked: 0
United States of America
jamadams11

Re: Engine dead after de grease wash 1990 240

Post by jamadams11 » Tue May 26, 2020 8:12 pm

crankshaft sensor only. I would remove each injector connector and check for moisture. the rubber boot can allow moisture in. blow dry connector and injector.

Michaeldiaz94520
Posts: 13
Joined: Mon May 25, 2020 7:06 pm
Year and Model: 1990
Location: Northern California
Has thanked: 0
Been thanked: 0
United States of America
Michaeldiaz94520

Re: Engine dead after de grease wash 1990 240

Post by Michaeldiaz94520 » Wed May 27, 2020 12:19 am

Update

So replaced crankshaft sensor
It made the engine light go off. Only thing is now the engine lets off a weird smell kinda like rotten eggs with hot electrical smell. . Could the water make the cat go bad ? The car runs , drove over an hour today no lights and no lag or dragging. Starts and drives . Aside from the smell it runs good . Noticed today though one time I started the car and the engine shook and made a rattle noise and then went away. That’s weird. .
Any suggestions ?
Thanks so much y’all

Post Reply
  • Similar Topics
    Replies
    Views
    Last post