IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Vibration noise when in Drive - mount gone?

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

John87
Posts: 1
Joined: Wed May 27, 2020 2:30 am
Year and Model: 2002 C70
Location: Scotland
Has thanked: 0
Been thanked: 0
Great Britain
John87

Vibration noise when in Drive - mount gone?

Post by John87 » Wed May 27, 2020 3:03 am

Hi folks, this is my first post, having been a long time lurker so my apologies!

I've recently bought this 2002 C70 2.0lpt as a fixer-upper and have already done quite a bit of work to her.. New PCV kit, steering rack, from calipers etc however this one has me puzzled!

I hear this droning vibration through the bulkhead when I am in Drive, either when accelerating hard or sitting idle with my foot on the brake. I've already replaced the upper and lower torque mounts (upper one was shot) but it's made no difference.

The noise disappears when there is no forward acceleration (therefore doesn't happen when in reverse or coasting). I've included a YouTube link of the symptom below..

Can anyone relate their experiences or suggest something else I may have to replace?

Thank you!


  • Similar Topics
    Replies
    Views
    Last post