IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

940 Regina starts fine, runs for a bit, then dies. Repeat.

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

User avatar
bharman
Posts: 5
Joined: Mon Mar 03, 2014 11:01 pm
Year and Model: 1993 940
Location: California
Has thanked: 2 times
Been thanked: 0
United States of America
bharman

940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by bharman » Tue Jun 02, 2020 2:11 pm

My 1990 B230 Regina has been sitting for a few months, ran sweetly before. Now it starts readily, idles, will go in gear for varying amounts of time, 30 seconds, to half a mile down the road, then it starts to sputter, cough, bogs badly on pressing gas, then dies. She starts right up immediately, idles and maybe gets me back home barely before quitting again. Put new fuel filter first, no change. In-tank pump works but I don't know how to check pressure, sock is fine. I removed the pulse regulator thing above the pump(some other thread said it might be leaking air), no change. Put a few gallons of fresh gas in, thought it might be spoiled gas, no change. Fuel lines all look fine. Changed out the radio suppression relay, no change. Swapped a used fuel pump relay, no change. The crank sensor wire looks fine. Any ideas?

User avatar
volvolugnut
Posts: 701
Joined: Sun Jan 19, 2014 9:51 am
Year and Model: 2001 V70
Location: Midsouth USA
Has thanked: 35 times
Been thanked: 75 times
United States of America
volvolugnut

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by volvolugnut » Tue Jun 02, 2020 6:33 pm

Will the car idle without moving for long enough to get to full warmup?

volvolugnut
2001 V70 T5, 1986 244DL, 1983 245DL, 1975 245DL, 1959 PV544, multiple parts cars.

User avatar
bharman
Posts: 5
Joined: Mon Mar 03, 2014 11:01 pm
Year and Model: 1993 940
Location: California
Has thanked: 2 times
Been thanked: 0
United States of America
bharman

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by bharman » Wed Jun 03, 2020 12:44 pm

Wow, no. It idled fine until needle started to climb, then it stumbled and died. What's that about?

User avatar
volvolugnut
Posts: 701
Joined: Sun Jan 19, 2014 9:51 am
Year and Model: 2001 V70
Location: Midsouth USA
Has thanked: 35 times
Been thanked: 75 times
United States of America
volvolugnut

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by volvolugnut » Wed Jun 03, 2020 1:59 pm

It could be related to the engine temperature sensor. If the sensor does not report the rising coolant temperature, the computer will continue to provide excess fuel for cold idling. I am not sure if this explains the restart and run after it died on the road.
Search this forum for temperature sensor. There are two.
volvolugnut
2001 V70 T5, 1986 244DL, 1983 245DL, 1975 245DL, 1959 PV544, multiple parts cars.

User avatar
bharman
Posts: 5
Joined: Mon Mar 03, 2014 11:01 pm
Year and Model: 1993 940
Location: California
Has thanked: 2 times
Been thanked: 0
United States of America
bharman

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by bharman » Wed Jun 03, 2020 6:47 pm

So, I pulled the old coolant temp sensor, cleaned the contacts, put a new one in. No change in the condition. Starts, idles for a while, chugs and dies. Would the fuel pressure regulator be next?

User avatar
bharman
Posts: 5
Joined: Mon Mar 03, 2014 11:01 pm
Year and Model: 1993 940
Location: California
Has thanked: 2 times
Been thanked: 0
United States of America
bharman

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by bharman » Wed Jun 03, 2020 7:45 pm

Update: Put a known fuel regulator on there, condition persists the same...

User avatar
volvolugnut
Posts: 701
Joined: Sun Jan 19, 2014 9:51 am
Year and Model: 2001 V70
Location: Midsouth USA
Has thanked: 35 times
Been thanked: 75 times
United States of America
volvolugnut

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by volvolugnut » Thu Jun 04, 2020 9:56 am

Check the Ohms of the coolant sensor at a known temperature. Repeat at a higher temperature. Use top radiator hose as the temperature reference. You can do this in the car if your arms are skinny. If you do not have the recommended Ohm rating, post here for more information. Contacts may be good and the sensor bad. I had to replace mine on '83 245 to fix rough idle after warm up.

volvolugnut
These users thanked the author volvolugnut for the post:
bharman
2001 V70 T5, 1986 244DL, 1983 245DL, 1975 245DL, 1959 PV544, multiple parts cars.

Bodhi5
Posts: 6
Joined: Mon Jun 15, 2020 1:31 am
Year and Model: 2001 s40
Location: Toronto
Has thanked: 0
Been thanked: 1 time
Canada
Bodhi5

Re: Solution for all Volvo idling reving, stall, dies

Post by Bodhi5 » Mon Jun 15, 2020 2:10 am

Hi, I've always bought old beater projects for 25yrs, from 244 turbos, to Honda, Toyota, now got ,s40. I've noticed many YouTube n forum complaints about idling, reving, stall, n engine dies.

These are electrical problems caused by:
1) loose battery terminals,
2) uncharged dying battery under 10volts,
3) rusted negative blue wire terminals to engine n frame, under battery.
4) dead alternator not charging battery properly,
5) bad plug wire n solid state coil sparkers.
6) engine idle control that YouTubers allege get dirty from controlling air intake to cylinders. Not sure about this, I haven't changed this yet, but maybe in a month will.

I do notice that all Volvo's do not sand off paint to steel frame when grounding negative terminal to frame under battery. This can cause rough idling cause spark cannot return to battery n alternator, and paint can disrupt this because there is oil insulators silicon, sealers that slow, prevent electrical flow.

Volvo engines are great, I've seen some go to 1 million miles like Honda's Toyota's. U just have to keep electrical, plugs, coolant oil flowing. Buy one of the new genius battery multi chargers, tester. If u run low on sulfuric acid in battery, try vinegar or clear coca cola.

Hope this helps everyone!
Cheers.
These users thanked the author Bodhi5 for the post:
bharman

User avatar
bharman
Posts: 5
Joined: Mon Mar 03, 2014 11:01 pm
Year and Model: 1993 940
Location: California
Has thanked: 2 times
Been thanked: 0
United States of America
bharman

Re: 940 Regina starts fine, runs for a bit, then dies. Repeat.

Post by bharman » Thu Jun 18, 2020 12:56 am

Solution update on my problem! It was an oxygen sensor connection problem by the catalytic converter. I cleaned my idle air control valve, almost bought a new one (phew), checked my coil pack, seemed to be ok, almost lost my mind, then read yet another forum reply and checked my oxygen sensor. A wire was broken. Problem solved.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post