IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

08 xc90 lost canbus? Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

08 xc90 lost canbus?  Topic is solved

Post by 2000c70hpt » Thu Jun 04, 2020 3:29 pm

Ok so here’s what’s going on. Started loosing fuel pressure after fixing a stuck float on the pump side of the tank. Got a code for the fuel rail pressure sensor. Changed it out ran great for a few days. Symptoms came back, so I figured what the hell. Let’s change the pem too. Yay fuel pressure normal runs great! Now all of a sudden I have no communication with the ecm, tcm, bcm, and sas modules. I have no broken wires, while doing a basic canbus test 2.7v on the high side, 2.3v to the low side and 60ohms while the vehicle is in pos 2. Now as soon as I start the car, it idles and runs all day perfectly as long as I am moving. If I start it and let idle for a few minutes, the gear indicator goes from P to - in the display. This tells me bad tcm, as the codes in vida correlate that. But it’s also saying lost comm with ecm as well. So I put a used ecm in (not expecting to be able to start it cause of wrong software) and I still have no communication with the above modules. Anyone got any ideas?

The is an 08 xc90 3.2l non turbo, fwd.
Last edited by 2000c70hpt on Thu Jun 04, 2020 6:10 pm, edited 1 time in total.
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

Re: 08 xc90 lost can us?

Post by 2000c70hpt » Thu Jun 04, 2020 3:40 pm

Forgot to mention. I do have vida dice
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
yagger
Posts: 304
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 5 times
Been thanked: 22 times
Belarus
yagger

Re: 08 xc90 lost can us?

Post by yagger » Thu Jun 04, 2020 4:16 pm

In ideal case, you have to use oscilloscope for check signal on CAN bus.
But, you can start from:
check top connectors on CEM for water damages,
disconnect DEM connector for confirm DEM is ok or no.
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

Re: 08 xc90 lost can us?

Post by 2000c70hpt » Thu Jun 04, 2020 6:04 pm

No water on the cem as I’ve already had it out looking for corrosion and popped surface mount components. Dem? Do you mean the dim? Driver info module? Checked it. The only oddity I’ve noticed was a 10 mile discrepancy between the dim and vida.
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
yagger
Posts: 304
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 5 times
Been thanked: 22 times
Belarus
yagger

Re: 08 xc90 lost canbus?

Post by yagger » Thu Jun 04, 2020 7:49 pm

DEM - Differential Electronic Module
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

Re: 08 xc90 lost canbus?

Post by 2000c70hpt » Fri Jun 05, 2020 5:05 am

My vehicle is not equipped with that module. It's only front wheel
On a side note i put the original pem back in since my issues I think started after the change
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

Re: 08 xc90 lost canbus?

Post by 2000c70hpt » Fri Jun 05, 2020 4:08 pm

Well a little update. I reinstalled the original pem and regained communication with the rest of the modules. Though I’m have fuel pressure issues again. From cold start it runs great. This morning I even let it idle for 30 minutes and then took it for a drive and ran great. After sitting for. 4 hours fuel pressure issues started again, and check engine light came on.
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
yagger
Posts: 304
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 5 times
Been thanked: 22 times
Belarus
yagger

Re: 08 xc90 lost canbus?

Post by yagger » Fri Jun 05, 2020 4:16 pm

Do you have a list of errors?
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

User avatar
2000c70hpt
Posts: 40
Joined: Fri Mar 27, 2020 9:11 am
Year and Model: 2000 C70
Location: Florida
Has thanked: 0
Been thanked: 0
United States of America
2000c70hpt

Re: 08 xc90 lost canbus?

Post by 2000c70hpt » Sat Jun 06, 2020 6:02 am

Still lost tcm and a code for the little bulb in the antenna

Edit: After serious testing today I regained comm with the car. Though the tcm had to be disconnected. All wires check out, fuses good, I’m at a loss. It’s really starting to look like a tcm. Does anyone know if a used one with a software update will work? Or do I have to use a new one.
2000 C70 hpt with 140k
2008 xc90 t6 non turbo with 170k

User avatar
yagger
Posts: 304
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 5 times
Been thanked: 22 times
Belarus
yagger

Re: 08 xc90 lost canbus?

Post by yagger » Sat Jun 06, 2020 1:28 pm

Still lost tcm
Can you do screenshot of errors and Network tab also?
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

Post Reply
  • Similar Topics
    Replies
    Views
    Last post