IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

'04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Post Reply
User avatar
E Showell
Posts: 3133
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 20 times
Been thanked: 70 times
United States of America
E Showell

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by E Showell » Wed Jun 10, 2020 11:02 am

The new coils all had new boots. I did not detect any holes or tears on the plug boots when I swapped them around.

More and more I am thinking failed MAF.

Ran like a champ when I pulled the MAF electrical connector, but I am not getting any MAF-specific codes on VIDA.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic
'95 855 auto (sold)
'86 245 manual (sold)
'05 V70 T5 M (totalled)
'06 V70 FWD Auto (totalled)

User avatar
boet
Posts: 5
Joined: Wed Nov 14, 2012 2:33 pm
Year and Model: 2002 V70
Location: Rye ,Texas
Has thanked: 0
Been thanked: 0
United States of America
boet

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by boet » Wed Jun 10, 2020 12:07 pm

May be check the wiring from the coils to where it connects into the main loom connector.

User avatar
boet
Posts: 5
Joined: Wed Nov 14, 2012 2:33 pm
Year and Model: 2002 V70
Location: Rye ,Texas
Has thanked: 0
Been thanked: 0
United States of America
boet

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by boet » Wed Jun 10, 2020 12:11 pm

Have you got a wiring diagram ?

User avatar
E Showell
Posts: 3133
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 20 times
Been thanked: 70 times
United States of America
E Showell

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by E Showell » Wed Jun 10, 2020 12:36 pm

No, I do not. Electricity and wiring aren't my strong suits either.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic
'95 855 auto (sold)
'86 245 manual (sold)
'05 V70 T5 M (totalled)
'06 V70 FWD Auto (totalled)

User avatar
E Showell
Posts: 3133
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 20 times
Been thanked: 70 times
United States of America
E Showell

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by E Showell » Fri Jun 12, 2020 4:34 pm

Replaced MAF with new purchased from FCP (none available at Harry's). Problem solved.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic
'95 855 auto (sold)
'86 245 manual (sold)
'05 V70 T5 M (totalled)
'06 V70 FWD Auto (totalled)

User avatar
RickHaleParker
Posts: 4384
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 556 times
United States of America
RickHaleParker

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by RickHaleParker » Sat Jun 13, 2020 1:37 am

E Showell wrote:
Fri Jun 12, 2020 4:34 pm
Replaced MAF with new purchased from FCP (none available at Harry's). Problem solved.
Last month I cleaned the MAF electrical connector on my S40. Misfiring problem solved.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

User avatar
E Showell
Posts: 3133
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 20 times
Been thanked: 70 times
United States of America
E Showell

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by E Showell » Sat Jun 13, 2020 4:12 am

So, not solved. Son went to use car for work this morning. Lumpy idle back. I'm going to have to put VIDA back on the job and see if I can glean any more useful data. Bad throttle body?

Pulled two throttle bodies at Harry's yesterday, but part numbers don't correlate to what FCP says I need. Ones I pulled end in "53". FCP says I need a "54". Last one I pulled came from the same model and year and had a completely different part number (starting in "36") than the FCP part number. I did not keep the 36 since it looked really beat. Another source suggested they were all interchangeable. Thoughts on that?

And just so you don't think I am a complete idiot, the "53" throttle bodies I did pull both had original Volvo markings on them and both came from cars FCP said should have had the "54" throttle bodies per their fitment guide.

Also, I would be eternally indebted to anyone who can tell me how the throttle body wiring harness clips work. In the three throttle bodies I pulled at Harry's, I utterly destroyed the clips to get them off. Could not for the life of me loosen them for removal.
Last edited by E Showell on Sat Jun 13, 2020 6:00 am, edited 2 times in total.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic
'95 855 auto (sold)
'86 245 manual (sold)
'05 V70 T5 M (totalled)
'06 V70 FWD Auto (totalled)

User avatar
abscate
MVS Moderator
Posts: 21460
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 333 times
Been thanked: 1035 times
Trinidad & Tobago
abscate

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by abscate » Sat Jun 13, 2020 4:55 am

The intermittent nature of this is making me think throttle body.

Headed to NY this morning, will noodle on it

VIDA will tell you about throttle action of course
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
E Showell
Posts: 3133
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 20 times
Been thanked: 70 times
United States of America
E Showell

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by E Showell » Sat Jun 13, 2020 1:54 pm

VIDA back on it.

No misfire codes. Faulty throttle code.

Sort term fuel trim both sensor banks at zero (open loop). Long term trim both banks at 99%. Not sure what all that means as it relates to throttle, but VIDA readout said idle rpm at 200.

This looks like a throttle body problem to me.
'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic
'95 855 auto (sold)
'86 245 manual (sold)
'05 V70 T5 M (totalled)
'06 V70 FWD Auto (totalled)

User avatar
RickHaleParker
Posts: 4384
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 556 times
United States of America
RickHaleParker

Re: '04 XC Engine Misfiring-Further Updated (Moisture ruled out - possible defective coils, bad MAF)

Post by RickHaleParker » Sat Jun 13, 2020 4:26 pm

E Showell wrote:
Sat Jun 13, 2020 4:12 am
In the three throttle bodies I pulled at Harry's, I utterly destroyed the clips to get them off. Could not for the life of me loosen them for removal.
Spray them with WD40 and let it soak down in between the two plastic connectors. Most of the time they slide apart afterwards.
These users thanked the author RickHaleParker for the post:
E Showell
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post