IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

V70 II dashboard doesn't show speed, rpm etc.

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

s3bi
Posts: 11
Joined: Thu Nov 21, 2019 11:06 pm
Year and Model: 850, 2.5L 10V, 1996
Location: Germany
Has thanked: 16 times
Been thanked: 0
Germany
s3bi

V70 II dashboard doesn't show speed, rpm etc.

Post by s3bi » Mon Jun 08, 2020 12:49 pm

Hi,

my mother's Volvo V70 II 2.4L from 20032004 has a problem with the dashboard:
volvov70_problem_tacho.jpeg
This is how it looks when the motor is running. All the four pointer instrument don't work (RPM should be around 800 otherwise for example). The two text displays in the middle just shows gibberish.
The indication lights in the lower right and the display in the lower left are the only things that work as they should.
Is this a known problem? Like a cold solder joint or a loose or corroded connector? If so, could it be something that's not located in the dashboard itself? (Just so that I don't remove it for nothing.)
I already tried to disconnect the battery for 10 minutes and bumping the dashboard with my fist a bit, but it didn't help.

Thanks for your answers.
Last edited by s3bi on Mon Jun 08, 2020 3:32 pm, edited 1 time in total.

User avatar
oragex
Posts: 4882
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 97 times
Been thanked: 277 times
Contact:
Canada
oragex

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by oragex » Mon Jun 08, 2020 1:55 pm

How did it happen ? All of a sudden ? Being fine just before ? Normally these silver rings are normally from 2004 when the DIM was upgraded to a better quality one. But maybe the connector behind has a problem. Any other engine/transmission problem ?

User avatar
yagger
Posts: 303
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 5 times
Been thanked: 22 times
Belarus
yagger

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by yagger » Mon Jun 08, 2020 2:49 pm

Looks like need to fix or replace DIM.
Volvo electronics and programming.Yagger&Doublebug - our experience invaluable.
Aftermarket Online Data Transferring Service for Volvo Pass: total

User avatar
abscate
MVS Moderator
Posts: 21460
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 333 times
Been thanked: 1035 times
Trinidad & Tobago
abscate

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by abscate » Mon Jun 08, 2020 3:04 pm

Or you have warts in your standard.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

s3bi
Posts: 11
Joined: Thu Nov 21, 2019 11:06 pm
Year and Model: 850, 2.5L 10V, 1996
Location: Germany
Has thanked: 16 times
Been thanked: 0
Germany
s3bi

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by s3bi » Mon Jun 08, 2020 3:31 pm

oragex wrote:
Mon Jun 08, 2020 1:55 pm
How did it happen ? All of a sudden ? Being fine just before ?
All of a sudden. Apparently it worked this afternoon and when my father reparked the car in the evening it didn't work anymore.
oragex wrote:
Mon Jun 08, 2020 1:55 pm
Normally these silver rings are normally from 2004 when the DIM was upgraded to a better quality one.
Sorry, I looked up the wrong date in the car registration, it's actually one year younger, it was first registered in June 2004. I wrote down the number 6. which seems to be the date of the EEC type approval which was 2003.
oragex wrote:
Mon Jun 08, 2020 1:55 pm
But maybe the connector behind has a problem. Any other engine/transmission problem ?
The car runs fine otherwise.

User avatar
oragex
Posts: 4882
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 97 times
Been thanked: 277 times
Contact:
Canada
oragex

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by oragex » Tue Jun 09, 2020 5:14 am

Try looking with a flash light under the dash, see which CEM you have (look up on Ebay CEM 2003 vs 2004), the 2004-up one is prone to water ingress and may affect the DIM. You may even see water marks on it, especially if it did rain recently. Saying this because normally only the 02-03 DIM without the silver rings go bad, and when they do, it's not all gauges and it starts rather intermittent. May still have a bad rear connector (need to disconnect the car battery when removing it), but my guess goes to a wet CEM. Also measure the alternator (engine at idle, measure at the battery posts) and the battery (engine off, disconnect pos cable, wait 1h then measure) while there, just in case
These users thanked the author oragex for the post:
s3bi

Jonboy74
Posts: 87
Joined: Wed Oct 05, 2011 3:17 pm
Year and Model: V70 2.4T, 2002
Location: USA - North Carolina
Has thanked: 54 times
Been thanked: 6 times
United States of America
Jonboy74

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by Jonboy74 » Wed Jun 10, 2020 10:40 pm

Listen to Oragex.

And if you do unplug it, make absolutely sure you disconnect the battery before you do, otherwise you'll end up with a false SRS error on the dash and you won't be able to get a safety inspection until that error is cleared....and you can't clear that without VIDA and a DiCE module.

And....if you end up having to have a DIM repair done, I highly suggest you read my post here:

viewtopic.php?t=87853

Good luck, and let us know how you do!

Jonboy
02 V70 2.4T
263,000 miles and counting
These users thanked the author Jonboy74 for the post:
s3bi

s3bi
Posts: 11
Joined: Thu Nov 21, 2019 11:06 pm
Year and Model: 850, 2.5L 10V, 1996
Location: Germany
Has thanked: 16 times
Been thanked: 0
Germany
s3bi

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by s3bi » Sun Jun 14, 2020 8:27 pm

oragex wrote:
Tue Jun 09, 2020 5:14 am
Try looking with a flash light under the dash, see which CEM you have (look up on Ebay CEM 2003 vs 2004), the 2004-up one is prone to water ingress and may affect the DIM. You may even see water marks on it, especially if it did rain recently. Saying this because normally only the 02-03 DIM without the silver rings go bad, and when they do, it's not all gauges and it starts rather intermittent. May still have a bad rear connector (need to disconnect the car battery when removing it), but my guess goes to a wet CEM. Also measure the alternator (engine at idle, measure at the battery posts) and the battery (engine off, disconnect pos cable, wait 1h then measure) while there, just in case
Doesn't look like there was ever water inside. The connector also looks ok.
v70_dashboard_open.jpg
v70_dashboard_open_back.jpg
I got it out of the car now and removed the cover on the front and back. However it doesn't look like the ones that people repaired on YouTube etc. The part that moves the needles is mounted on the PCB. I'm not sure how I can pull the PCB off to check the soldering on the other side. I don't want to damage these actuators or the mechanical part that hold the needles. Does anyone know if I can just pull them off?

jonesg
Posts: 973
Joined: Wed Jan 16, 2008 3:25 pm
Year and Model: 2004 V70
Location: Northern maine.
Has thanked: 2 times
Been thanked: 24 times
Wales
jonesg

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by jonesg » Sun Jun 14, 2020 10:45 pm

Thats the instrument panel, I think Oragex was talking about the module that resides near your knees when you sit behind the wheel.
you are looking for this,
These users thanked the author jonesg for the post:
s3bi

User avatar
abscate
MVS Moderator
Posts: 21460
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 333 times
Been thanked: 1035 times
Trinidad & Tobago
abscate

Re: V70 II dashboard doesn't show speed, rpm etc.

Post by abscate » Mon Jun 15, 2020 4:50 am

The 2004 models had a problem with the rubber gasket that leaked water into the CEM , I’ll try find the TSB document and link/ post here.
These users thanked the author abscate for the post:
s3bi
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Post Reply
  • Similar Topics
    Replies
    Views
    Last post