IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

CEL (but goes off between 3k en 4k+ RPM)

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

850T5Ritalia
Posts: 24
Joined: Fri Oct 11, 2019 2:19 am
Year and Model: 1995 T-5R
Location: Earth
Has thanked: 1 time
Been thanked: 1 time
Italy
850T5Ritalia

CEL (but goes off between 3k en 4k+ RPM)

Post by 850T5Ritalia » Tue Jun 09, 2020 8:35 am

Hi,

A little context. I have a '95 T5R 850 MT with a B5234T4 engine.
I recently swapped to a Motronic 4.4 ECU (stock 4.3). All the necessary mods have been done to make sure the 4.4 works on the former 4.3 car.

Since I cant read any codes (yet), because of not having had time to fit an obd2 port and the old "dignostic box under the bonnet not working on 4.4 i'm hoping somebody knows or experienced this strange CEL behaviour.

When resetting the ECU all is fine for the first 5 miles or so. After that the CEL starts coming on when accelarating above 3/4k rpm. that goes on for a while till is 'stabalizes' to being a permanent CEL that goes off between 3/4k rpm.

I know it's a long shot but since I dont have time to fix a obd2 port any time soon I wanted to ask if somebody might have an idea what could be going on since its not very typical CEL behaviour.

note: I swapped back the 4.3 ECU to see if that would throw a code (which i would then be able to read from the box under the bonnet) but it doenst give a CEL on 4.3.

Thanks

  • Similar Topics
    Replies
    Views
    Last post