IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Volvo S80 problem

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
chakalisa
Posts: 4
Joined: Fri Jun 12, 2020 2:24 pm
Year and Model: 2003/s80
Location: Gaborone
Has thanked: 0
Been thanked: 0
Botswana
chakalisa

Volvo Repair Database Volvo S80 problem

Post by chakalisa » Fri Jun 12, 2020 2:35 pm

my volvo S80 2.9l 2003 model is giving me problems, is just cranking not starting. it started by flashing the engine light and stopped. i diagnosed it and got a system relay ECM 801A faulty. where is that relay located? Anyone help

bronco
Posts: 112
Joined: Sun Aug 11, 2019 7:21 pm
Year and Model: 1998 V70
Location: boston
Has thanked: 3 times
Been thanked: 11 times
United States of America
bronco

Re: Volvo S80 problem

Post by bronco » Sat Jun 13, 2020 6:23 pm

drivers side under hood box ? guessing but someone else will chime in shortly I'm sure with more detail

I have a 2002 here but there is no decal on the lid :roll:

I say decal but I actually refer to it as the map of the fusebox , regardless its missing. Might try a google image search 2003 S80 fusebox

User avatar
RickHaleParker
Posts: 4382
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 556 times
United States of America
RickHaleParker

Re: Volvo S80 problem

Post by RickHaleParker » Sun Jun 14, 2020 4:08 am

ECM-801A System relay. Faulty signal or signal missing

Condition
Diagnostic trouble code (DTC) ECM-801A is stored if the voltage from the system relay to the control module is greater than 2.5 V but lower than 3 V (signal missing) or if the power supply for the control module to the electronic throttle module is lower than 8 V (faulty signal). The fault is diagnosed when the ignition is on.

Substitute value
None.

Possible source
Signal missing
  • Faulty charging system
    Contact resistance in the terminals
    Open-circuit in the signal cable for the system relay
    Faulty system relay.
Faulty signal
  • Faulty charging system
    Contact resistance in the terminals
    Faulty system relay.
Fault symptoms
The engine fails to start
The engine runs poorly.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

chakalisa
Posts: 4
Joined: Fri Jun 12, 2020 2:24 pm
Year and Model: 2003/s80
Location: Gaborone
Has thanked: 0
Been thanked: 0
Botswana
chakalisa

Re: Volvo S80 problem

Post by chakalisa » Tue Jun 16, 2020 1:20 am

ok thanks Rick, where is the system relay located

User avatar
RickHaleParker
Posts: 4382
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 556 times
United States of America
RickHaleParker

Re: Volvo S80 problem

Post by RickHaleParker » Wed Jun 17, 2020 2:41 am

chakalisa wrote:
Tue Jun 16, 2020 1:20 am
ok thanks Rick, where is the system relay located
FMA2
2020-06-17.png
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

chakalisa
Posts: 4
Joined: Fri Jun 12, 2020 2:24 pm
Year and Model: 2003/s80
Location: Gaborone
Has thanked: 0
Been thanked: 0
Botswana
chakalisa

Re: Volvo S80 problem

Post by chakalisa » Wed Jun 17, 2020 6:14 am

thanks Rick, i have checked all my relays and they are fine. I wonder where could the problem be...i now suspect my ECU.

chakalisa
Posts: 4
Joined: Fri Jun 12, 2020 2:24 pm
Year and Model: 2003/s80
Location: Gaborone
Has thanked: 0
Been thanked: 0
Botswana
chakalisa

Re: Volvo S80 problem

Post by chakalisa » Wed Jun 17, 2020 6:49 am

I don't have signal to the coils, no spark at all.

bronco
Posts: 112
Joined: Sun Aug 11, 2019 7:21 pm
Year and Model: 1998 V70
Location: boston
Has thanked: 3 times
Been thanked: 11 times
United States of America
bronco

Re: Volvo S80 problem

Post by bronco » Wed Jun 17, 2020 8:16 am

just as a goof maybe swap the engine relay with one of the others that is the same type

Post Reply
  • Similar Topics
    Replies
    Views
    Last post