IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

High Idle when car has been running for a while

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

High Idle when car has been running for a while

Post by lcc014 » Wed Jun 17, 2020 6:43 pm

This problem happened in around late April when we had the stay home advisory. When car is "cold" idle is fine, in park or waiting for traffic light. Once the car is driven for a while - "hot", idle speed goes up above 1300 rpm in Park position and a bit over 1000 rpm while waiting for traffic light.

Initially, I cleaned the IAC and the valve inside was moving freely when I shake the IAC. I also cleaned the throttle body too, not too much black deposit around the front and back side of the throttle body valve. Test drove the car after cleaning, same issue.

Then I got a new IAC from Volvo dealer and installed it. Still the same idle issue when car is "hot".

My car is 1995 NA wagon, what could be the problem here to cause the high idle in Park or waiting for traffic light ?

Thanks,

Ching-Ho Cheng
Last edited by lcc014 on Thu Jun 18, 2020 5:00 am, edited 2 times in total.

User avatar
RickHaleParker
Posts: 4413
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 562 times
United States of America
RickHaleParker

Re: High Idle when car has been running for a while

Post by RickHaleParker » Wed Jun 17, 2020 10:01 pm

Check for DTCs, Air leaks intake and exhaust, stuck/leaking EGR.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: High Idle when car has been running for a while

Post by lcc014 » Thu Jun 18, 2020 5:00 am

There is no CEL. I will check the DTC anyway. Exhaust manifold was replaced a while ago due to the flex elbow leak. EGR was replaced years ago when I did the PCV replacement. How to check air leaks in intake, exhaust and EGR valve ?

Thanks,

Ching-Ho Cheng

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: High Idle when car has been running for a while

Post by lcc014 » Thu Jun 18, 2020 3:23 pm

I checked DTC code and found one in A2: 233 (Idle Air Trim Exceeds Control Limits); A1 had no code (111). So any more suggestion to troubleshoot the issue ?

Thanks,

Ching-Ho Cheng

User avatar
misha
Posts: 4412
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 145 times
Serbia
misha

Re: High Idle when car has been running for a while

Post by misha » Thu Jun 18, 2020 4:17 pm

A6?
Being a '95 it should have Jetronic LH 3.2 management will can have 2 separate ecu(s),one for engine and the other for ignition.
Last edited by misha on Thu Jun 18, 2020 5:07 pm, edited 1 time in total.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: High Idle when car has been running for a while

Post by lcc014 » Thu Jun 18, 2020 4:56 pm

I have not tried A6. I only know A1 and A2 are for engine and transmission. I will try A6 to see any DTC.

Thanks,

Ching-Ho Cheng

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: High Idle when car has been running for a while

Post by lcc014 » Thu Jun 18, 2020 5:45 pm

Just went out to check for A6 DTC. There was no code, meaning, no LED lighted up in A6 socket. I had tried 4 times, no LED light up. I could see the female connector inside A6 hole, but just no LED light up when compared with A1, A2, etc...

Thanks,

Ching-Ho Cheng

User avatar
RickHaleParker
Posts: 4413
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 562 times
United States of America
RickHaleParker

Re: High Idle when car has been running for a while

Post by RickHaleParker » Thu Jun 18, 2020 7:57 pm

Volvo 850 modules and Flash codes. Smoke injection is the best leak detector. You can use starting fluid on the intake side of a running engine for leak detection. When a leak sucks in starting fluid you will hear the engine surge.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

User avatar
misha
Posts: 4412
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 145 times
Serbia
misha

Re: High Idle when car has been running for a while

Post by misha » Fri Jun 19, 2020 1:16 am

Open up ecu box.
If it's Jetronic...it will have 2 ecu(s) in ecu box....for a car with manual transmission and 3 ecu(s)...for a car with automatic transmission.
That said...
-2 ecu for engine and ignition for a car with manual transmission
-3 ecu for engine,ignition and TCM(transmission control module) for car with automatic transmission.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

lcc014
Posts: 156
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: High Idle when car has been running for a while

Post by lcc014 » Fri Jun 19, 2020 4:56 am

misha wrote:
Fri Jun 19, 2020 1:16 am
Open up ecu box.
If it's Jetronic...it will have 2 ecu(s) in ecu box....for a car with manual transmission and 3 ecu(s)...for a car with automatic transmission.
That said...
-2 ecu for engine and ignition for a car with manual transmission
-3 ecu for engine,ignition and TCM(transmission control module) for car with automatic transmission.
Thank you for the information. If it is not Jetronic then it will have 2 modules (Engine & TCM); is that correct ?

Thanks,

Ching-Ho Cheng

Post Reply
  • Similar Topics
    Replies
    Views
    Last post